
5. Explore files and folders 

In this chapter 

Understand files, folders, and libraries 

Get to know File Explorer 

Change the File Explorer display options 

Find specific files 

You view all the drives, folders, and files that are stored on your computer and 

on storage drives it is connected to through a network or over the internet, in File 

Explorer. File Explorer can display the contents of a folder, a library of folders, 

or a virtual collection of items (such as the Quick Access list). 

To simplify the way that you work with files, Windows presents files in File 

Explorer as though the files are organized in a hierarchical storage system of 

folders and subfolders (folders within folders). In reality, files are stored on the 

computer’s hard drive and in other locations (such as Microsoft OneDrive) 

wherever they fit, and the storage structure that File Explorer displays is only a 

series of pointers to the files. This provides you with easy access to files while 

still maintaining an organizational system. 

You can organize files in folders and create virtual libraries of folders so that 

you can access files in multiple ways. If you forget where you stored a file, you 

can use the simple yet powerful search features of Windows 10 to quickly locate 

files and other information on your computer based on the file name, content, or 

type. 

This chapter guides you through procedures related to getting to know File 

Explorer, changing the File Explorer display options, and searching for files. 

Understand files, folders, and libraries 
There are many different types of files, but they all fall into these two basic 

categories: 

Files used or created by apps These include executable files (such as the 

Microsoft Office app files) and dynamic-link libraries (DLLs) (files used by 



apps to provide functionality). Some of these files might be hidden (not 

shown in a standard folder window view) to protect them from being 

inadvertently changed or deleted. 
 

 

Files created by you These include documents, worksheets, graphics, text 

files, presentations, audio clips, video clips, and other things that you can 

open, look at, and change by using one or more apps. 

The files that are installed with an app and those it creates for its own use are 

organized the way the app expects to find them, and you shouldn’t move or 

remove them. However, you have complete control of the organization of the 

files you create (such as documents and worksheets), and knowing how to 

manage these files is essential if you want to be able to use your computer 

efficiently. 

Folders 

As with files, there are also many different types of folders, but they fall 

generally into two categories: folders created by Windows or apps and folders 

created by you to organize your files. Creating folders is covered in “Create and 

rename folders and files” in Chapter 6, “Manage folders and files.” 

When Windows 10 was installed on your computer, it created system folders, 

including these: 

Program Files folder Many apps install the files they need in subfolders of 

the Program Files folder. You might have the option to choose a different 

folder, but there’s rarely a reason to do so. After you install an app, you 

shouldn’t move, copy, rename, or delete its folders and files; if you do, you 

 

 

 

 



might not be able to run or uninstall the app. 
 

 

Users folder For each user account on the computer, Windows also creates 

a user account folder in the Users folder. The user account folder contains 

several subfolders, referred to in this book as your personal folders. Some 

of your personal folders are visible in your user account folder, which is 

located at C:\Users\[account name]. 
 

 

 

 

 

 

 

 

 

 



 
 

There is also a hidden folder named AppData that contains information 

about your user account settings for Windows and for apps that you use. 

Windows creates the user account folder and its subfolders the first time a 

user signs in. As you work on your computer and personalize Windows, 

Windows saves information and settings specific to your user profile in 

these folders. 

In addition to the account-specific folder for each user account that is active 

on the computer, the Users folder also contains a Public folder, the contents 

of which are accessible to anyone who is logged on to the computer. The 

Public folder contains subfolders. Some of these are visible, such as 

Documents, Downloads, Music, Pictures, and Videos. The hidden 

subfolders contain information about settings that are common to all user 

accounts on the computer. If you want to make files available to anyone 

who logs on to the computer, you can store them in the Public folders rather 

than in your personal folders. 
 

 

Windows folder Most of the critical operating system files are stored in 

this folder. You can look, but unless you really know what you are doing, 

don’t touch! Most Windows 10 users will never need to access the files in 

the Windows folder. 

 

 

 

 

 



Libraries 

You can display a collection of folders that you want easy access to in a library. 

Libraries are virtual folders that aren’t physically present on the hard drive but 

that display the contents of multiple folders as though the files were stored 

together in one location. 

The default Windows 10 installation includes seven standard libraries: Camera 

Roll, Documents, Music, Pictures, Podcasts, Saved Pictures, and Videos. In 

previous versions of Windows, the libraries included user account folders and 

their corresponding Public folders, but in Windows 10 the default starting 

content is your user account folder. Configuring a OneDrive connection on your 

computer adds your OneDrive Documents, Music, and Pictures folders to the 

corresponding libraries. 

In Windows 10, libraries are hidden by default in File Explorer. You can turn on 

the display of libraries if you want to use them. 

You manage a library from the Manage tab that appears when you select or open 

a library in the Libraries window. (Tabs that appear only in specific contexts are 

called contextual tabs or tool tabs, because they host tools for working with the 

selected file or folder.) 



 
 

You can add folders from any connected location to libraries, and some apps add 

folders to libraries for you when you make selections. 



 
 

In addition to the standard libraries, you can create your own libraries, and a 

folder can belong to more than one library. For example, suppose you are 

working on a Fall Promotion project for a client, Contoso Pharmaceuticals. If 

you create one library that displays all the folders of your current projects and 

another library that displays all the folders associated with Contoso, you can 

include the Fall Promotion folder in both libraries. 

If you don’t use libraries, you can choose to not display the Libraries node at the 

root of the Navigation pane. 
 

 

 

 

 



 
 

 

Get to know File Explorer 
Early versions of Windows displayed physical hard drives at the root of the file 

storage structure. As file management and storage practices have evolved—first 

to include virtual libraries of folders and now to commonly include OneDrive 

and other cloud storage locations—File Explorer has also evolved. At the root of 

the storage structure, File Explorer displays a series of conceptual organizational 

systems, including the following nodes: 

Quick Access Contains links to folders and files that you access frequently 

or pin here for easy access 

This PC Contains links to your user account–specific folders, and to the 

physical storage locations that are installed in or connected to your 

computer 

Libraries Contains links to virtual collections of folders, which by default 

are composed of the user account–specific folders and their corresponding 

OneDrive folders 

Network Displays a representation of other computers on your local area 

network 

Homegroup Displays a representation of other computers on your local 

area network that are joined to the network homegroup 

 

 

 

 

 



 
 

 

When you connect your Windows 10 computer to OneDrive or OneDrive for 

Business cloud storage drives, those drives also appear at the root of the storage 

structure. 

Within the This PC node, File Explorer displays the user-specific file storage 

folders and the storage devices that are connected to your computer. Storage 

locations included in This PC include hard drives installed in the computer and 

storage devices (such as CDs, DVDs, USB flash drives, and external hard drives) 

that are physically connected to the computer. Each storage drive that is 

physically connected to the computer is identified by a letter, and in some cases 

 
 

 

 



by a description. Your computer’s primary hard drive (the one where the 

operating system is installed) is almost always identified by the letter C. (By 

tradition, the letters A and B are reserved for floppy disk drives, which are all but 

obsolete and have been superseded by higher-capacity storage media.) If your 

computer has additional built-in hard drives, they are assigned the next 

sequential letters, followed by any removable media drives. 
 

 

To explore your computer’s storage system, you can use the This PC window as 

a convenient entry point. The devices represented in This PC are divided into 

groups. Internal hard drives (those physically installed in your computer) and 

external hard drives (those connected to your computer by a cable) are shown 

first, followed by internal removable storage drives (such as CD and DVD 

drives) and external removable storage devices (such as USB flash drives), and 

then storage locations you access through a network connection. For each drive 

or device, the total storage space and available storage space are given, both as 

actual measurements and visually as a colored progress bar. The length of the 

progress bar indicates the portion of the total storage space that is in use. The 

default bar color is aqua; when less than 10 percent of the storage space on a 

drive or device remains available, the bar color changes to red. 

The File Explorer window layout includes the following elements: 
 

The ribbon This command interface has commands organized in groups on 

tabs. The File menu and ribbon tabs are covered later in this topic. 

Navigation pane This vertical pane is open by default on the left side of the 

window. It displays a hierarchical view of the physical and virtual storage 

structures available to the computer. You can browse to folders and files on 

your computer or network by selecting locations in this pane. 

Content pane This primary pane displays the contents of the selected folder 

as a textual or iconic list. You can’t close the content pane. 

 

 

 

 



Details pane This pane displays information about the selected folder or 

file. 

Preview pane This pane displays a preview of the file that is selected in the 

content pane. The Preview pane can display the contents of image files, 

Microsoft Word documents, Excel workbooks, PowerPoint presentations, 

PDF files, and other common file types. 
 

 

 

 

 

 



Work with the standard ribbon tabs 

The ribbon in File Explorer includes the File menu, a set of standard tabs, tabs 

that are displayed for specific folders, and tabs that appear only when specific 

types of items are selected. These context-sensitive tabs, also called tool tabs, 

host commands that you need only when you select an item of that type. Tool 

tabs are covered in the “Work with the tool tabs” section later in this topic. 

The standard ribbon elements are: 
 

File menu The File menu displays commands in the left pane and a list of 

recently or frequently displayed folders on the right. You can invoke 

commands and open specific locations from the File menu. 
 

 

You can pin locations to the Frequent Places list by selecting the thumbtack 

icon. Pinned locations stay at the top of the list and are indicated by angled 

thumbtacks. 

 

 

 

 



Home tab The Home tab is available when File Explorer is displaying 

anything other than the This PC, Network, and Homegroup nodes. 

Commonly used commands are grouped on the Home tab. 
 

 

Share tab The Share tab provides various ways for you to share a folder or 

file with other people. These options include sending a copy of a file to 

other people or sharing its location with other people who are on your 

network. In addition to sharing options, the Share tab provides commands 

for printing, burning a file to a disc, and compressing a file. 
 

View tab The View tab hosts the commands that you can use to customize 

the display of items in the File Explorer window. 
 

The Home tab provides access to the most commonly used File Explorer 

commands. Many of them are covered in depth later in this chapter, but some 

deserve a quick mention, such as the following: 

Pin to Quick access This adds the selected folder to the Quick Access list 

at the top of the Navigation pane. This list is available from within apps and 

in File Explorer. 

Easy access This command displays a menu that offers various ways to 

make the current location more easily accessible. 



 
 

Open and Edit When a folder is selected in the content pane, selecting the 

Open button expands the folder. The Edit button is disabled. When you 

select an editable file (such as a Word document) in the content pane, both 

the Open and Edit buttons will open the file. The difference is that when 

you select the arrow next to Open, you get a list of all the programs known 

to File Explorer that can open this file type, and an option to choose a 

default one. 

History This displays the current file in the File History viewer. 
 

 

The View tab provides access to several commands you can use to tailor File 

Explorer to suit your preferences. Many of these tabs are discussed in greater 

detail in “Change the File Explorer display options” later in this chapter. 

The following commands are the most commonly used: 
 

Navigation pane Select this to display a list of Navigation pane features 

you can turn on or off, including the display of the pane itself. 

 
 

 

 



 
 

Preview pane and Details pane You can display either of these panes, but 

only one at a time. The active pane appears on the right side of File 

Explorer. When the Preview pane is active, selecting a file displays the file 

content in the preview pane. If the Details pane is active, selecting a file 

displays its icon and file information such as its size. 

Layout commands These commands determine whether the files are 

displayed as icons of various sizes or one of two types of list. 
 

 

Current view commands Sort By allows you to select the column to sort 

by. You can also do this by selecting a column title. Select it again to reverse 

the sort. Select Group By and Add Columns to see the options for each. 

Show/hide commands The three check boxes in Show/Hide turn the 

display of their respective items on and off. You can select one or more 

items (files or folders) and select Hide Selected Items to mark them as 

hidden. Then select or clear the Hidden Items check box to display or hide 

them in the content pane. To unhide the items, first show all hidden items, 

 

 

 

 



then select the hidden items, and select Hide Selected Items to turn it off. 
 

 

Options The Options command displays the Folder Options dialog box, 

which we discuss in “Change the File Explorer display options,” later in 

this chapter. 

Work with the tool tabs 

Tool tabs appear on the ribbon when specific storage locations are displayed or 

specific types of files are selected. Tool tabs are in named groups of one or more 

tabs that host commands specific to working with the selected file type. (Most 

groups have only one tab.) A colored tab in the title bar displays the tool tab 

group name. The tool tab or tabs are below the group tab and to the right of the 

standard tabs. For example, when you select an image file, the Manage tool tab 

in the Picture Tools group appears; when you select an audio file, the Play tool 

tab in the Music Tools group appears; and when you select a compressed folder 

(a zip file), the Extract tool tab in the Compressed Folder Tools group appears. 
 

 

 

 

 

 

 

 

 

 



 
 

There are theoretically more than 200 tool tabs, each with its own combination 

of commands. The storage locations that have their own tabs include This PC, 

Drive, Network, Homegroup, Search, Library, and Recycle Bin. The file types 

that display tool tabs when you select them include ISO, ZIP, Image, Audio, 

Video, and Shortcut file types. 

For example, when you select This PC in File Explorer, the Home and Share 

tabs are replaced by the Computer tab. This tab contains links to common 

functions and tools that you can use to manage your computer. You can point to 

each command on the Computer tab to display a ScreenTip explaining its 

purpose. 
 

 

When you select a hard drive in the Navigation pane, the Manage tool tab in the 

Drive Tools group appears. 

 

 

 

 



 
 

If you have a local network, you can select the icon for it in the Navigation pane. 

Commands appropriate to the network are displayed on the Network tab. 
 

Even the Recycle Bin has its own tool tab. When you double-click the desktop 

icon for the Recycle Bin, the Manage tab in the Recycle Bin Tools group appears 

on the ribbon. 
 

From this tool tab, you can empty the Recycle Bin or restore deleted items. 

Work with the Navigation And Search bar 

The Navigation And Search bar is displayed just below the ribbon. You can use 



the commands on this bar to quickly navigate through the folder structure. 
 

 

To the immediate right of the folder navigation arrows is the Address bar. The 

Address bar displays an icon and the friendly path to the current folder. Selecting 

the folder icon at the left end of the Address bar displays the absolute path from 

the root drive. Each item in the friendly path has a > after it. If you select a >, the 

folders within that item are displayed, and you can select one to open it. You can 

drag the icon to another location, such as the desktop, to create a shortcut to this 

folder at that location. You can right-click anywhere in the Address bar to 

display the shortcut menu. 

To the right of the Address bar are the Refresh button and the search box. 

Selecting the Refresh button is the same as pressing the F5 key: it refreshes the 

display. The search box is one of those special locations that produces a tool tab. 

Search is discussed in more detail in “Find specific files,” later in this chapter. 

To start File Explorer 
 

On the Start menu, select File Explorer. 

On the taskbar, select the File Explorer button. 

Select Win+E. 

Right-click the Start button and then on the Quick Links menu, select File 

Explorer. 

To display the contents of a folder in File Explorer 

In the Navigation pane, select the folder name. 

In the content pane, double-click the folder name. 

To expand or collapse a folder in the Navigation pane 

Double-click the folder, or select the < to the left of the folder name. 



To move through a list of recent locations 
 

At the left end of the Navigation and Search bar, select the Back and 

Forward buttons. 
 

To move directly to a location 
 

1. In File Explorer, on the Navigation and Search bar, do either of the 

following: 

Select the Recent locations button (the v between the Forward and Up 

buttons) to display a menu of recent locations. 

Select the Previous Locations button (the v at the right end of the 

Address box) to display a menu of previous locations. 

2. Select the location you want to move to. 
 

 

To move up one level in the current folder path 
 

In File Explorer, on the Navigation and Search bar, select the Up button 

(the upward-pointing arrow to the left of the Address box). 

Work with libraries 

The Libraries node that is optionally displayed in the File Explorer Navigation 

pane is more conceptual than most other folders. Rather than containing files and 

folders, it points to folders that might exist on your hard drive, on a USB drive, 

or even on a hard drive on someone else’s computer on a network you can access. 
 

 

 

 

 



 
 

Libraries are shortcuts to folders that you can navigate to individually, but that 

you want quicker access to. For example, the Documents library might include 

pointers to your private Documents folder, to the Public Documents folder, and 

to the Documents folder in your OneDrive folder. When you add a file to one of 

those folders, and it is indexed, it shows up in the Documents library. 

You can add folders from any connected location to an existing or new library. 

Until the library contains at least one folder, it displays a button labeled Include 

a folder. 
 

One of the benefits of managing file locations within libraries is that the Libraries 

node and all the folders it points to are included by default in File History 

backups. 
 

 

 

 

 

 



 
 

You can optimize individual libraries for specific file types—either documents, 

music, pictures, or videos—to set sorting and grouping options specific to that 

file type. To further personalize the library, you can assign one of over 400 icons 

to it. 
 

If you no longer use a library, you can delete it without affecting the files and 

folders it contains, or you can simply hide it so that it doesn’t appear in the 

Navigation pane. 

 



 
 

You manage a library and its contents from the Manage tool tab or the library 

Properties dialog box. 

To display or hide the Libraries node in the Navigation pane 
 

In File Explorer, on the View tab, in the Panes group, select Navigation 

pane, and then Show libraries. 



To open a library in File Explorer 
 

In the Navigation pane, select the Libraries node. Then in the content 

pane, double-click the library you want to open. 

In the Navigation pane, select the > to the left of the Libraries node, and 

then select the library you want to open. 

To open the Properties dialog box for a library 
 

In File Explorer, right-click the library, and then select Properties. 
 

To create a library 
 

1. In the File Explorer Navigation pane, do either of the following: 

Right-click the Libraries node. 

Select the Libraries node and then right-click an empty area of the 

content pane. 

2. Select New, and then Library to create the library with the name active for 

editing. 

3. Enter a name for the new library, and then press Enter. The icon remains 

neutral until you choose a content type. 
 

 

 

 

 
 



 
 

To add a folder to a library 
 

1. Do either of the following: 

Open the library in File Explorer. On the Manage tool tab, in the Manage 

group, select Manage library to open the Library Locations dialog box 

specific to the library. 
 

Open the Properties dialog box for the library. 

2. Select Add to open the Include Folder In dialog box for the library. 

3. Browse to and select the folder you want to include, and then select Include 

folder to add the folder to the library. 

4. Select OK to close the dialog box. 
 

To optimize a library or folder for a file type 
 

Open the library’s Properties dialog box. In the Optimize this library for 

list, select General items, Documents, Music, Pictures, or Videos. Then 

 



select Apply or OK. 

In File Explorer, display the Libraries node, and then select the library you 

want to optimize. On the Manage tool tab, select Optimize library for, 

and then in the list, select General items, Documents, Music, Pictures, or 

Videos. 

To change the folder icon of a custom library 
 

1. Do either of the following to open the Change Icon dialog box: 

Open the library in File Explorer. Then on the Manage tool tab, select 

Change icon. 

Open the library’s Properties dialog box and select Change library 

icon. 

2. In the Change Icon dialog box, select the icon you want to use, and then 

select OK. 

To remove a folder from a library 
 

Open the library’s Properties dialog box, select the folder, and select 

Remove. Then select Apply or OK. 

Open the library’s Library Locations dialog box, select the folder, and 

then select Remove. Then select OK. 

To hide a library in the Navigation pane 
 

In the library’s Properties dialog box, clear the Shown in navigation pane 

check box. Then select Apply or OK. 
 

 

 

 

 



 

 

Change the File Explorer display options 
Windows 10 provides many ways to personalize the display of File Explorer to 

suit the way you work. 

Display and hide panes 

Each pane of the File Explorer window displays a specific type of information. 

You can display and hide some panes to show or hide information, or to change 

the amount of space available in the content pane. For example, if your folders 

typically contain many files and you are adept at navigating in the Address bar, 

you might want to turn off the Navigation, Detail, and Preview panes so that the 

content pane occupies the entire folder window. 

To display or hide the File Explorer Navigation pane 
 

1. In File Explorer, on the View tab, in the Panes group, select Navigation 

pane. 

2. Select or clear the Navigation pane check box to display or hide the pane. 
 

To display or hide the File Explorer Preview pane 
 

Select Alt+P. 

On the View tab, select Preview pane. 
 

To display or hide the File Explorer Details pane 
 

Select Alt+Shift+P. 

On the View tab, select Details pane. 
 

 

 

 

 



 
 

Display different views of folders and files 

You use commands on the View tab to set the layout, sort order, grouping, and 

columns that are displayed in the content pane. You can choose to display a 

check box column (the boxes appear only when you point to or select items), file 

name extensions, and hidden files. 
 

 

The standard information displayed for files in Details view includes the file 

name, date modified, type, and size. You can add a lot more information to the 

Details view to make it more useful to you. For example, you can display the 

dimensions of images, the number of pages in a document, or the number of 

slides in a PowerPoint presentation. Having these types of details available 

directly from File Explorer can save you a lot of time and effort. Over 300 

properties are available for display in File Explorer. Most apply only to specific 

file types, but many could be useful to you. 

When the Details pane is open, it displays detailed information when you select 

a single file. As you select more files, the Details pane displays the number of 

items selected, the total size of the files, and other types of information common 

to the selected files. 

 

 

 

 



 
 

If you add a folder to the selection, the Details pane displays only the number of 

items selected (the folder is counted as one item, regardless of the number of 

subfolders and files in it) and a stack of icons. 

Different views are best suited to different tasks. For example, when you are 

looking for a specific graphic among those stored in a folder, you might find it 

useful to be able to see the graphic thumbnails in the content pane. 

The available views include the following: 
 

Icons The four Icon views (Extra Large, Large, Medium, and Small) 

display an icon and name for each folder or file in the current folder. In all 



but Small Icons view, the icons display either the file type or, in the case of 

graphic files (including PowerPoint presentations), a representation of the 

file content. 

List This view is like Small Icons view in that it shows the names of the 

files and folders accompanied by a small icon that represents the file type. 

The only difference is that the items are arranged in columns instead of in 

rows. 

Details This view displays a list of files and folders, each accompanied by a 

small icon that represents the item type and its properties, arranged in a 

tabular format, with column headings. The properties shown by default for 

each file or folder are Name, Date Modified, Type, and Size. You can hide 

any of these properties, and you can display a variety of other properties 

that might be pertinent to specific types of files, including Author and Title. 

Tiles For folders, this view displays a medium-size icon and the folder 

name and type. For files, the icon indicates the file type and is accompanied 

by the file name, type, and file size. 

Content For folders, this view displays an icon, the folder name, and the 

date. For files, the icon indicates the file type and is accompanied by the file 

name, type, file size, and date. 
 

 

To change the File Explorer folder view 
 

On the View tab, in the Layout group, select a layout option. 
 

 
 

 

 

 

 

 

 



 

 

Right-click an empty spot in the content pane, point to View, and then 

select a view from the list. 

In the lower-right corner of the content pane, select the Details or Large 

Icons button. 
 

 

To display folder content as icons 
 

On the View tab, in the Layout group, select Extra Large icons, Large 

icons, Medium icons, or Small icons. 
 

To display folder content as a list of items and their properties 
 

On the View tab, in the Layout group, select Details. 

To add, remove, or rearrange properties in Details view 

1. In File Explorer, display the contents of the folder as a detailed list. 

2. Do either of the following to open the Choose Details dialog box: 

On the View tab, in the Current view group, select Add columns and 

then Choose columns…. 

Right-click any column header, and then select More…. 

 

 

 

 



 
 

3. In the Choose Details dialog box, do any of the following: 

Select a column name to add or remove its check mark, which adds or 

removes that column from Details view. 

Select a column name, and then select Show or Hide to show or hide that 

column in Details view. 

Select a column name, and then select Move Up or Move Down to move 

the column higher or lower on the list, which also moves the column to 

the left or right in Details view. 

To resize a column in Details view 
 

In File Explorer, point to the line between the column heading and the 

heading to its right, and when the mouse pointer changes to a double- 

headed arrow, do any of the following: 

Drag to the left to make the column narrower. 

Drag to the right to make the column wider. 

Double-click to make the column resize to fit the widest item in the 

column. 
 

To resize all columns in Details view to fit the widest item in the column 



On the View tab, in the Current view group, select Size all columns to fit. 
 

To display or hide folder features and content 
 

In File Explorer, on the View tab, in the Show/hide group, do any of the 

following: 

To turn on or off the display of check boxes when you point to or select 

an item, select or clear the Item check boxes check box. 

To show or hide each file name extension (for example, .docx), select or 

clear the File name extensions check box. 

To show or hide hidden items, select or clear the Hidden items check 

box. 

Group, sort, and filter folder content 

By default, the folders and files in the content pane are displayed in alphabetical 

order by name, with the subfolders at the top and files below them. You can sort 

or group the items in a folder or library in any view, by any default or displayed 

property. The default options include Name, Date Modified, Type, Size, Date 

Created, Authors, Categories, Tags, and Title. The Sort By and Group By menus 

display the currently available properties; to sort or group by a hidden property, 

display the property first to add it to the menu, and then return to the menu to 

sort or group the folder or library contents. 



 
 

 

If you group folders and files, their overall arrangement changes, but within each 

group the sort order remains the same. You can change the order of the items in 

the content pane by sorting them by any of the displayed properties. 
 

 

 

 

 

 

 

 

 



Options for sorting and grouping content are available from the View tab, and 

also from the shortcut menu that appears when you right-click an empty area of 

the content pane. Although both options are very similar, the ribbon menus 

display a few more options. 

If a folder contains a lot of files, or contains subfolders of files, you can filter the 

folder content to display only the files that meet specific conditions. Filtered 

results include individual files, whether they are at the top level of the folder or 

within subfolders. 

To group folder content 
 

1. On the View tab, in the Current view group, select Group by. If a property 

has a dot to its left, items in the folder are already grouped by that property. 

2. If the Group by list doesn’t include the property you want to group by, 

select Choose columns, select the property in the Choose Details dialog 

box, and then select OK. 

3. In the Group by list, select the file property you want to group items by. 
 

To ungroup folder content 
 

On the View tab, in the Current view group, select the Group by button, 

and then select (None) from the bottom of the list. 

To sort files in any view 
 

1. On the View tab, in the Current view group, select Sort by. If a property 

has a dot to its left, items in the folder are already sorted by that property. 

2. If the Sort by list doesn’t include the property you want to sort by, select 

Choose columns, select the property in the Choose Details dialog box, and 

then select OK. 

3. In the Sort by list, select the file property you want to sort items by. 
 

To sort folder content in Details view 
 

Select the column name you want to sort by. 

Selecting the column name once sorts in alphabetical or ascending 

numerical order. 



Selecting the column name a second time sorts in reverse alphabetical or 

descending numerical order. 

A ^ or v appears in the middle of the column heading to let you know the 

column is sorted in ascending or descending order. 

To filter folder content 
 

1. In File Explorer, display the contents of the folder as a detailed list. 

2. Point to a column header until a v appears at its right edge. 

3. Select the v to display a list of items you can filter on. (The list content is 

specific to the properties of the items in the folder.) 
 

4. Select a check box to show only those items in the list that match the filter. 

Each filter is applied when you select it, so you can immediately see its 

impact. 
 

 

5. Click or tap outside the list to close it. 

Change folder options 

 
 

 

 



Most of the common folder options you might want to change are included on 

the File Explorer ribbon. However, some less common ones are available when 

you select the Options button (not the arrow) at the right end of the View tab. 

In the Folder Options dialog box, you can customize folder windows by 

changing settings on these two tabs: 

General On this tab, you can change how you browse folders, whether you 

select or double-click to open items, and how the Navigation pane behaves. 

View On this tab, you can change the default view for all folders and change 

specific display/hide settings. For example, you can specify whether to show 

the status bar in File Explorer windows. 
 

 

 

 

 

 



 
 

To display the Folder Options dialog box from File Explorer 
 

On the File menu, select Options or Change folder and search options. 

On the View tab, select the Options button, or select the Options arrow 

and then select Change folder and search options. 

To change the default File Explorer starting folder 
 

1. In the Folder Options dialog box, display the General tab. 

2. Select the Open File Explorer to list, and then select either Quick access 

or This PC. 

3. Select OK. 
 

To change how you select to open an item 
 

1. In the Folder Options dialog box, on the General tab, do either of the 

following: 

Select Single-click to open an item (point to select). 

Select Double-click to open an item (single-click to select). 

2. Select OK. 
 

To add a location to your Quick Access list 
 

Select the folder in File Explorer, and then do either of the following: 

On the Home tab, in the Clipboard group, select Pin to Quick access. 

In the content pane, right-click the folder, and then select Pin to Quick 

access. 

To hide items in the Quick Access list 

 



1. In the Folder Options dialog box, on the General tab, do either of the 

following: 

Clear the Show recently used files in Quick access check box. 

Clear the Show frequently used folders in Quick access check box. 

2. Select OK. 
 

 

Find specific files 

Windows 10 provides various ways to search everything from a folder on your 

computer to the web, all from the taskbar search box. File Explorer provides an 

additional search capability that is limited to files only (that is, it doesn’t return 

apps and web searches). The underlying search engine is the same from all these 

locations, but the focus of the searches and the way the results are returned 

varies. 

Windows Search 

Recent advancements in online and computer search technology have made the 

instant location of information and files so simple that it’s easy to forget how 

tedious tracking down the same items would have been in the past. The search 

technology that is built in to Windows 10 is excellent. 

Using Windows Search, you can find apps, files, messages, and message 

attachments on your computer. You don’t need to know the name or location of 

the file or item you want to find; simply enter a word or phrase in the taskbar 

search box to display a list of matching items, organized by type. 

How does Windows Search find items so quickly? Behind the scenes, Windows 

 

 

 

 



Search maintains an index of all the keywords in, and associated with, the files 

stored on your computer—app names, common tasks, and the file names and 

content (when possible) of documents, audio and video recordings, images, 

email messages, webpages, and other data files. Windows Search automatically 

indexes the most common file types (such as documents, text files, and email 

messages) and doesn’t index file types you are less likely to search (such as 

operating system files). It does not include the system files; such an index would 

be huge and would slow down the search process. 

When you enter a search term, Windows looks for the term in the index instead 

of searching the actual files on your hard drive. 
 

 

File Explorer Search 

File Explorer Search differs from Windows Search in that it is limited to 

searching for files and displays them in its own familiar interface. So when you 

get a results list, you can use all the usual commands on the View tab to refine 

the display. 

You initiate a File Explorer Search from the Search box at the right end of the 

Navigation And Search bar. When you activate this box to enter a search term, 

the Search Tools group tab appears, providing tools you can use to refine your 

search. 

 

 

 

 



 
 

You can save a set of search parameters so that you can display updated results 

at any time. Saved searches are added to the Favorites group in File Explorer and 

are also available from your personal Searches folder. 

To search for a file in File Explorer 
 

In the upper-right corner of the File Explorer window, enter a search term 

in the Search box. As you enter the search term, Windows filters the 

program files, folders, and email messages stored on your computer. 

To refine a File Explorer search 
 

On the Search tool tab, in the Refine group, select the property by which 

you want to filter the search results, and then enter the criteria for the filter. 

To save a search for later reference 
 

1. On the Search tool tab, in the Options group, select the Save search 

button. The Save As dialog box displays the content of your personal 

Searches folder. 

2. In the Save As dialog box, select Save to accept the default name and save 

the search in the Searches folder. 
 

 

Key points 

 
 

 
 



File Explorer is the app in which you display and access the files stored on 

your computer. Files are organized into folders. Some folders are created by 

Windows, some by apps, and some by you. You can also create virtual 

libraries of files. 

You can display additional file properties in File Explorer, and group, sort, 

and filter files by any displayed property. 

You can limit a search to files and to specific file locations by searching 

from the File Explorer search box. 
 

  Practice tasks 
Before you can complete these practice tasks, you need to copy the book’s 

practice files to your computer. The practice files for these tasks are located in 

the Win10SBS\Ch05 folder. The introduction includes a complete list of 

practice files. 

Understand files, folders, and libraries 

There are no practice tasks for this topic. 

Get to know File Explorer 

Perform the following tasks: 
 

1. Start File Explorer, and navigate to the practice file folder. 

2. Open the Photos folder, and then open the Backgrounds subfolder. 

3. Use the tools on the Navigation and Search bar to move up to the Ch05 

folder. 

4. In the Navigation pane, contract all the expanded storage nodes. Then 

review the locations in the Navigation pane and ensure you’re familiar with 

each. 

5. In the Navigation pane, double-click This PC. Review the file storage 

locations that are connected to your computer. 

6. On the View tab, display the Navigation pane menu. If the Navigation pane 

isn’t already configured to display libraries, display them now. 



7. Expand the Libraries node. Create a new library named Win10SBS and 

ensure that it appears in the Navigation pane. 

8. Add the Backgrounds subfolder of the Ch05\Photos folder to the new 

Win10SBS library. 

9. Optimize the Win10SBS library for the display of photos. Then assign an 

icon that you like to the library folder. 

10. Hide the Win10SBS library from the Navigation pane. Then unhide it. 

Change the File Explorer display options 

Start File Explorer, and then perform the following tasks: 
 

1. Navigate to the practice file folder and expand its contents in the content 

pane. 

2. Experiment with the settings in the Panes group on the View tab to hide 

and redisplay the Navigation pane. 

3. Display the Details pane. Select a file in the content pane and notice the 

available details. Select a different type of file, and then select multiple 

files, noting the details available for each. 

4. Display the Preview pane and repeat the process in step 3. For each file that 

displays a preview, observe the preview content and notice the controls 

available in the Preview pane for scrolling or moving through the preview. 

5. Resize the Preview pane by dragging its border. 

6. Experiment with the settings in the Layout group on the View tab. Display 

the content of the practice file folder in each of the eight available layouts. 

Consider the information provided by each layout and when each would be 

most or least useful. 

7. Display the Details view of the practice file folder content. 

8. From the Add columns list, navigate to the longer list of columns and 

select Dimensions to add that column to the Details view. 

9. Rearrange the columns in the content pane so that the Dimensions column 

is immediately to the right of the Name column. 

10. Resize all columns to fit the widest item in the column. 

11. Remove the Date Created and Dimensions columns from the Details view. 



12. Display item check boxes, file name extensions, and hidden items. 

13. Group the items by type. 

14. Sort the grouped items alphabetically by name. Then reverse the sort order. 

15. Filter the items by using the Size filter to display only large items (1-16 

MB). 

16. Remove the filter, restore the default sort order, and remove the file 

grouping. 

17. Add the Photos folder to your Quick Access list. 

Find specific files 

Display the practice file folder in File Explorer, and then perform the following 

tasks: 

1. Search for a file from the File Explorer search box by using the search term 

travel. 

2. Refine the search by narrowing the results to items that are small (between 

10 and 100 KB). 

3. Save the search for later reference. 

4. Return from the Search Results folder to the original folder. 
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