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                        Experiment No.7 

Loop Antenna 

This example is intended to show you how to create, simulate, and 

analyze a 10 Meter loop Antenna using the Ansoft HFSS Design 

Environment. 

 

 

 

 

 

 

 

 

Ansoft HFSS Design Environment: 

The following features of the Ansoft HFSS Design Environment 

are used to create this passive device model: 

3D Solid Modeling: 

Primitives: Cylinders, Sphere 

Boolean: Union, Subtract, Connect 

Boundaries/Excitations: 

Excitations: Wave Ports 

Boundaries: Radiation 

Results: 

Plotting: Radiation Pattern 
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Design Review: 

Port Size/Type: 

Since the port is external to the model we could use a Wave Port. 

The size of the port is determined by the physical dimensions of the sheet 

created by gap inside the feed of loop antenna.  

Free Space: 

Since we are evaluating a radiating structure, we need to create a 

free space environment for the device to operate in. This can be achieved 

by using the Radiation Boundary condition. We will use a Radiation 

Boundary since the surface will be rectangular box. The Radiation 

Boundary needs to be placed at least l/4 from radiating devices.  

Getting Started: 

Launching Ansoft HFSS: 

To access Ansoft HFSS, click the Microsoft Start button, select 

Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 

10. 

Setting Tool Options: 

To set the tool options: 

Note: In order to follow the steps outlined in this example, verify 

that the following tool options are set: 

1. Select the menu item Tools > Options > HFSS Options 

2. HFSS Options Window: 

1. Click the General tab Use Wizards for data entry when creating new 

boundaries: _ Checked 

Duplicate boundaries with geometry: _ Checked 

2. Click the OK button 

3. Select the menu itemTools > Options > 3D Modeler Options. 

4. 3D Modeler Options Window: 
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1. Click the Operation tab 

Automatically cover closed polylines: _ Checked 

2. Click the Drawing tab 

Edit property of new primitives: _ Checked 

3. Click the OK button 

Opening a New Project: 

To open a new project: 

    1. In an Ansoft HFSS window, click the _ On the Standard toolbar, or 

select the menu item File > New. 

    2. From the Projectmenu, select Insert HFSS Design. 

 

 

 

 

 

 

 

 

 

 

 

Set Solution Type: 

To set the solution type: 

1. Select the menu item HFSS > Solution Type 

2. Solution Type Window: 
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1. Choose Driven Modal 

2. Click the OK button 

 

Creating the 3D Model: 

Set Model Units: 

To set the units: 

1. Select the menu item 3D Modeler > Units 

 2. Set Model Units: 

          1. Select Units: meter 

          2. Click the OK button 

Set Default Material: 

To set the default material: 

Using the 3D Modeler Materials toolbar, choose copper 

Create Circular Waveguide: 

Create upper rib of antenna 

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 0.0, Z: 0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY: 0.0, dZ:1.326 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: L_1 

3. Click the OK button 

To fit the view: 
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1. Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

Create Circular rib of antenna: 

Create lower rib of antenna 

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 0.0, Z: -0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY: 0.0, dZ:-1.326 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: L_2 

3. Click the OK button 

To fit the view: 

1. Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

Create Circular rib of antenna: 

Create rib of antenna corresponding to previous the upper and lower 

ribs 

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 2.692, Z: -1.346 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY: 0.0, dZ:2.692 Press the Enter key 
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To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: L_3 

3. Click the OK button 

To fit the view: 

1. Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

Set Grid Plane: 

To set the grid plane: 

1. Select the menu item 3D Modeler > Grid Plane >zx 

 

 

Create Horizontal Circular rib of antenna: 

Create horizontal rib of antenna  

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 0.0, Z: 1.346 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY:2.692, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: L_4 

3. Click the OK button 

To fit the view: 
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1. Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

 

 

 

Create Spherical join:  

Create Spherical join between ribs of antenna 

1. Select the menu item Draw >Sphere 

2. Using the coordinate entry fields, enter the 

sphere position 

X: 0.0, Y: 0.0, Z: 1.346 Press the Enter key 

3. Using the coordinate entry fields, enter the 

radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY:0.0, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Sphere1 

3. Click the OK button 

To fit the view: 

1. Select the menu item View > Fit All > Active 

View. 

Or press the CTRL+D key 

Create Spherical join: 

Create Spherical join between ribs of antenna 

1. Select the menu item Draw >Sphere 
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2. Using the coordinate entry fields, enter the sphere position 

X: 0.0, Y: 2.692, Z: 1.346 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Sphere2 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

 

 

 

 

Create Circular rib of antenna with two joints: 

To create circular rib of antenna with two joints: 

Create a Cylinder 

Position 0,0,-1.346 

Dx= 0.01 

Y=2.692 

Create spher 

Position :0,2.692, -1.346 

 Radius dx= 0.01 
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Create spher 

Position: 0,0, -1.346 

 Radius: dx= 0.01 

 

cylinder 

 

 

 

 

 

Create Horizontal Circular rib of antenna with two joints: 

Create horizontal rib of antenna corresponding to horizontal 

previous rib: 

1. Select the Attribute tab from the 3D modeler design tree. 

2. Select L_4, and select the menu item Toolbars > Mirror Duplicate. 

        1. Using the coordinate entry fields, enter the sphere position 

          X: 0.0, Y: 0.0, Z: 0.0 Press the Enter key 

        2. Using the coordinate entry fields, enter the radius: 

         dX: 0.0, dY: 0.0, dZ: 1.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: L_5 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 
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Or press the 

CTRL+D key 

Create Loop 

antenna: 

To create loop 

antenna from 

previous ribs 

created above: 

1. Select the 

Attribute tab from the 3D modeler design tree. 

2. Select all ribs starting from L_1, L_2, L_3, L_4 and L_5. 

3. Select the menu item Modeler > Boolean>Unite. 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Loop_Antenna 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 
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Create Horizontal Circular rib of The Feed: 

To create horizontal rib of the feed 

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 0.0, Z: 0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY:-1.743, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Feed_1 

To fit the view: 

Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

 

 

Create Spherical join: 

Create Spherical join between ribs of feed 

1. Select the menu item Draw >Sphere 

2. Using the coordinate entry fields, enter the sphere 

position 

X: 0.0, Y: 0.0, Z: 0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 
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dX: 0.0, dY:0.0, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Sphere3 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

Create Horizontal Circular rib of The Feed: 

To create horizontal rib corresponding to previous feed 

1. Select the menu item Draw > Cylinder 

2. Using the coordinate entry fields, enter the cylinder position 

X: 0.0, Y: 0.0, Z: -0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY:-1.743, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties 

window. 

2. For the Value of Name type: Feed_2 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active 

View. 

Or press the CTRL+D key 

Create Spherical join:  

Create Spherical join between ribs of feed 
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1. Select the menu item Draw >Sphere 

2. Using the coordinate entry fields, enter the sphere position 

X: 0.0, Y: 0.0, Z: -0.02 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX: 0.01, dY: 0.0, dZ: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the height: 

dX: 0.0, dY:0.0, dZ:0.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Sphere4 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 

Or press the CTRL+D key 

Create Loop antenna with transmission feed: 

To create loop antenna from all previous: 

1. Select the Attribute tab from the 3D modeler design tree. 

2. Select all ribs starting from Loop_Antenna, Feed1, Feed2, sphere3 

and sphere4. 

3. Select the menu item Modeler > Boolean>Unite. 

 Select the menu item View > Fit All > Active View. 

 Or press the CTRL+D key 
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Set Grid Plane: 

To set the grid plane: 

Select the menu item 3D Modeler > 

Grid Plane >YZ 

Create the Lumped Port 

To create a rectangular that represents the port: 

 1. Select the menu itemDraw > Rectangle 

 2. Using the coordinate entry fields, enter the center position 

 X: 0.0, Y: -1.743, Z: -0.01 Press the Enter key 

 3. Using the coordinate entry fields, enter the radius of the circle: 

 dX: 0.0, dY: 0.02, dZ: 0.02 Press 

the Enter key 
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To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: p1 

3. Click the OK button 

To select the object p1: 

1. Select the menu item Edit > Select > By Name 

2. Select Object Dialog, 

1. Select the objects named: p1 

2. Click the OK button 

Create Lumped Port Excitation:  

To assign lumped port excitation 

1. Select the menu item HFSS > Excitations > 

Assign >Lumped Port 

2. Wave Port: General 

1. Name: p1 

2. Click the Next button 

3. Lumped Port: Modes 

1. Number of Modes: 1 

2. For Mode 1, click the None column and select New Line 

3. Using the coordinate entry fields, enter the vector position 

  X:0.0, Y: -1.733, Z: 0.0 Press the Enter key 

4. Using the coordinate entry fields, enter the vertex 

dX: 0.0, dY:-1.733, dZ: 0.01 Press the Enter key 

5. Click the Next button 

6. Click the Finish button 
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Set Grid Plane: 

To set the grid plane: 

Select the menu item 3D Modeler > Grid Plane >XY 

Set Default Material 

To set the default material: 

Using the 3D Modeler Materials toolbar, choose vacuum 

Create Air: 

Create Air 

1. Select the menu item Draw >Box 

2. Using the coordinate entry fields, enter the cylinder position 

X:-3.0, Y: -3.0, Z:-4.5 Press the Enter key 

3. Using the coordinate entry fields, enter the radius: 

dX:6.0, dY: 9.0, dZ: 9.0 Press the Enter key 

To set the name: 

1. Select the Attribute tab from the Properties window. 

2. For the Value of Name type: Air 

3. Click the OK button 

To fit the view: 

Select the menu item View > Fit All > Active View. 
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Create Radiation Boundary: 

To create a radiation boundary: 

1. Select the menu itemEdit > Select > By Name 

2. Select Object Dialog, 

1. Select the objects named: Air 

2. Click the OK button 

3. Select the menu item HFSS > Boundaries > Assign> Radiation 

4. Radiation Boundary window 

1. Name: Rad1 

2. Click the OK button 
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Analysis Setup: 

To create an analysis setup: 

1. Select the menu itemHFSS > Analysis Setup > Add Solution Setup 

2. Solution Setup Window: 

1. Click the General tab: 

Solution Frequency: 28MHz 

Maximum Number of Passes: 10 

Maximum Delta S per Pass: 0.02 

2. Click the OK button 

Addingfrequency sweep Analysis Setup: 

To create an analysis frequency sweep setup: 

1. Select the menu itemHFSS > Analysis Setup > Add frequency sweep 

2. Solution Edit Sweep Window: 

1- Sweep name: Sweep1 

Sweep type: Fast 

2- Frequency setup: 

Type: linear setup 

Start: 0.1 MHz 

Stop: 40 MHz 

Step size: 0.01 MHz 

3- Save fields cheked 

Save Project: 

To save the project: 

1. In an Ansoft HFSS window, select the menu item File > Save As. 

2. From the Save As window, type the Filename: hfss_LoopA 

3. Click the Save button 

Model Validation 

To validate the model: 
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1. Select the menu item HFSS > Validation Check 

2. Click the Close button 

Note: To view any errors or warning messages, use the Message 

Manager. 

Analyze: 

To start the solution process: 

Select the menu item HFSS > Analyze All 

 

 

Create Reports: 

Create Terminal S-Parameter Plot - Magnitude 

To create a report: 

               1. Select the menu item HFSS > Results > Create Report 

               2. Create Report Window: 

                      1. Report Type: Terminal S Parameters 

                      2. Display Type: Rectangular 

                      3. Click the OK button 

              3. Traces Window: 

                      1. Solution: Setup1: Sweep1 

                      2. Domain: Sweep 

                      3. Click the Y tab 

                                    1. Category: Terminal S Parameter 

                                    2. Quantity: St (p1,p1), 

                                    3. Function: dB 

                                    4. Click the Add Trace button 

            4. Click the Done button 

            5. Select the menu Report 2D > Mark All Traces 

            Click the Min button. 
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Discussion: 

1- What are the difference between small square loop antenna and 

small circular? 

2- Why loop antenna used in angle finding application? 
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