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As you learned, “Understanding Microsoft Office 2010,” each Office 2010

application has the same basic controls, including a tabbed Ribbon, title

bar, status bar, scroll bars, and Backstage view.

Spreadsheets

help us to organize, calculate, and make sense of numeric data. Like the orderly

row-and-column format of a paper ledger, a spreadsheet enables users to organize

large amounts of data so that it is easy to understand and easy to refer to.



Workbook An Excel data file,

containing one or more worksheets.

Worksheet A tabbed page of a

workbook, containing a grid of rows

and columns.

Sheet area is the place where you type

your text

➢ Excel calls a data file a workbook.

➢ Each workbook, by default, contains

three tabbed pages.

➢ Each page is a worksheet.



1- Cell The intersection of a row and a

column in a worksheet.

2- Cell address The column letter and the

row number that intersect to form the cell,

such as B3 or A6.

3- Name box The box above cell A1 where

the name of the active cell appears.

4- Active cell The cell that the cell selector

is on. Any content entered will appear in

the active cell.

5- Cell selector The movable dark outline around the active cell.



Example :

formula in cell C4 is =C2+C3.

Because that cell is active,

you can see the formula in

the formula bar. Cell C4 itself

shows the result: 7. and

Name box shows the cell’s

address: C4. If the cell

contains a numeric value or a

text string, the formula bar

shows the same content as the

cell itself.

Formula bar The bar above the worksheet where the contents of the active

cell appear.

➢ If the active cell contains a formula, the formula appears in the formula

bar and the result of the formula appears in the cell itself.



Table : A group of cells that work together to store structured data.

To quickly create a table in Excel, do the following:

1. Select the cell or the range in the data.

2. Select Home→ Style group→Format as Table.

3. Pick a table style.

4. In the Format as Table dialog box, select the checkbox next to My table

as headers if you want the first row of the range to be the header row, and

then click OK.



There are two methods of converting a range to a table :

1. default table style

Use these steps to convert a range to a table and apply the default table style

to it:

1. Select the range.

2. On the Insert tab, click Table.

2. Choice of Style.

Use these steps to convert a range to a table and apply your choice of

table style to it:

1. Select the range.

2. On the Home tab→Format as Table.

3. Click the desired style.

After the table has been created, you can change the table style from the

Table Tools Design tab.



• In a table, each column is known as a field. A field contains a specific type

of structured data, such as Phone or Address.

• Each row is a record, containing all the fields for a specific instance.

To sort means to put records into a specific order according to the entry in a

certain field.

To sort a table, 

1. Click the down-arrow button to

the right of the field by which you

want to sort.

2. Opening a menu, and on that

menu, click Sort A to Z or Sort Z

to A, depending on whether you

want an ascending sort or

descending sort.



➢ field :A column in a table, storing one particular kind of information,

such as Phone or Name.

➢ Record :A row in a table, storing information about a specific person,

place, or thing.

➢ sort :To put records in a specific order according to the entry in a

certain field.

➢ Ascending sort: An A to Z sort, or a sort from smallest to largest.

➢ descending sort: A Z to A sort, or a sort from largest to smallest.



Filter :To hide certain records according to criteria you specify.

To clear a filter, display the Data tab and click Clear, or open the field’s

menu and choose Clear Filter from Fieldname.

You can filter a table by:

1. Exclude records that contain a

certain value in a certain field:

open a field’s menu at the bottom of

the menu, clear the check boxes for

any entries that you do not want to

be included.

2. Criteria you define :

open a field’s menu → point to Text

Filters (or Number Filters, or

whatever appears, depending on the

field data type) to open a submenu,

and then choose a filtering criterion,

such as Equals, Does Not Equal,

Begins With, or Ends With.



1. To type in a cell, you must make it the active cell, either by clicking it or by

using one of the keyboard methods of moving the cell selector.

2. Moving the cell selector is not the same as scrolling. When you scroll the

worksheet, you change which cells are visible, but you do not change the

active cell.

Any arrow key One cell in the direction of the arrow

Tab One cell to the right

Shift + Tab One cell to the left

Ctrl + arrow key To  last or first non-empty cell in the direction of the arrow

Ctrl + End To bottommost, rightmost cell of worksheet contains data

Ctrl + Home To the beginning of the worksheet

Home To the beginning of the active cell’s row

Page Down One screen down

Page Up One screen up

Alt + Page Down One screen to the right

Alt + Page Up One screen to the left

Ctrl + Page Down To the next sheet in the workbook

Ctrl + Page Up To the previous sheet in the workbook

3. To enter content

in a cell, make

the cell active by

moving the cell

selector to it, as

you learned in

the preceding

section, and then

just start typing.

4. When you are

finished, move to

another cell.
Keyboard Shortcuts for Moving the Cell Selector



To edit a cell’s content, make the cell active and 

then do any of the following:

1. To replace the cell’s content with a new entry,

type the new entry.

2. To edit the cell’s content without replacing it

entirely,

➢ Click in the formula bar and make your edits

there, Or

➢ Double-click the cell to move an insertion point

into it and then edit the text directly in the cell.

3. To clear all the text from the cell, press the

Delete key.

4. To clear both the text and the formatting from

the cell, click the Home tab, click the Clear

button, and click Clear All.



A range is one or more cells that are

selected at the same time.

• A range can be a single contiguous

rectangular block or multiple cells or

groups of cells from different

locations, including on different

worksheets.

Describing a Range

When a range is a contiguous rectangular

block, its name is written with the upper-

left cell address, a colon, and the lower-

right cell address, like this:

B2:C8. 

When a range contains non-contiguous

cells or blocks, the pieces are separated by

a semicolon, like this:

B2:C8 ; E2:E8.



Selecting a Range

1. To select an entire row, click its row number. 

2. To select an entire column, click its column letter. 

3. You can select multiple rows or multiple columns by dragging across the 

row numbers or column letters.

4. You can drag across a contiguous range to select it. 

5. To select a noncontiguous range with the mouse, hold down the Ctrl key as 

you drag across the blocks of cells to select and click the individual cells to 

select. Release the Ctrl key when you are done choosing cells to include.

6. You can also use keyboard shortcuts to select a range,

Ctrl + A The entire worksheet

Ctrl + spacebar The entire column of the active cell

Shift + spacebar The entire row of the active cell

Ctrl + Shift+ arrow key The last nonblank cell in the same column or row as the active 

cell, or if the next cell is blank, to the next nonblank cell

Ctrl + Shift + End The last non-empty cell on the worksheet (lower-right corner)

Ctrl+ Shift + Home Cell A1

Ctrl + Shift + Page Down The current and next sheets in the workbook

Ctrl+Shift+Page Up The current and preceding sheets in the workbook



Inserting Rows or Columns

Use these steps to insert one or more rows or

columns:

1. Select the row that the new row should appear

above or the column that the new column should

appear to the left of.

2. If you want to insert multiple rows or columns,

select multiple rows or columns. For example, to

insert three rows above row 10, you would select

rows 10, 11, and 12.

3. On the Home tab, click Insert.

Deleting Rows or Columns

Use these steps to delete one or more rows or

columns.

1. Select the row(s) or column(s) to delete.

2. On the Home tab, click Delete. OR Right-click

the selected range and choose Delete from the

context menu.



Inserting Cells

Use these steps to insert one or more cells:

1. Select a range where you want the new cells to be

inserted. It doesn’t matter if that range already

contains data.

2. On the Home tab, click the down arrow to the right

of the Insert button. The Insert dialog box opens.

3. Click the option button to describe what should

happen to the cells in the selected range.

4. Click OK.

Deleting Cells

Use these steps to delete one or more cells:

1. Select a range of cells that you want to delete.

2. On the Home tab, click the down arrow to the right

of the Delete button. The Delete dialog box opens.

3. Click the option button to describe what

surrounding cells should shift to fill in the vacated

space.

4. Click OK.



The orderly grid format of a worksheet means that you have the same

number of rows in each column, and the same number of columns in each row

usually. For special layout effects, you can merge two or more cells into a

single cell that occupies the same space as the two would have taken up

separately.

Merging Cells
Use these steps to merge contiguous cells:

1. Select the cells to merge. Keep in mind that only the text in

the upper-left cell will remain after the merge; it will

appear as the text in the merged cell.

2. On the Home tab, click the Merge and Center button.

Unmerging Cells
Use these steps to unmerge a merged cell:

1. Select the merged cell.

2. On the Home tab, click the down arrow to the right of the

Merge and Center button.

3. On the menu that appears, click Unmerge Cells. Note that

any text that was deleted as a result of the merge will not

return when the cell is unmerged.



➢ Excel uses standard operators for equations, such as a plus sign for addition

(+), minus sign for subtraction (-), asterisk for multiplication (*), forward

slash for division (/), and caret (^) for exponents.

➢ The key thing to remember when writing formulas for Excel is that all formulas

must begin with an equals sign (=). This is because the cell contains or is equal

to he formula and its value.

EXAMPLE1: create a simple formula in Excel:

1. Select the cell where the answer will appear

(B4).

2. Type the equals sign (=).

3. Type the cell address that contains the first

number in the equation (B1).

4. Type the operator you need for your

formula. For example, type the addition

sign (+).

5. Type the cell address that contains the

second number in the equation (B2).

6. Press Enter. The formula will be calculated,

and the value will be displayed in the cell.



A chart can help show the meaning of data in a graphical way.

For example, suppose you were presented with the data shown in

Figure below.

This data represents the sales

quantities for several products, but it is

difficult to gain any useful summary

information by browsing it. When

some of this data is presented in charts,

as in the figure below, you can

immediately discern some useful facts



Types of Charts and Their Uses

Excel can create many types of charts.

1- The pie charts

2- Column chart

3- Scatter chart

• Charts can be two-dimensional, or three-

dimensional.

• When a chart’s bars run horizontally instead of

vertically, it is called a bar chart.

• Variants of both bar and column charts are

available with cylindrical or pyramid-shaped

bars.

• You can create a chart by selecting the data for it

and then choosing a chart type from the Charts

group on the Insert tab.

• A newly created chart appears as a floating

object on the active sheet, in its own frame.

• You can drag it around, resize it, or move it to its

own Sheet tab.



Step by Step

➢ Creating a Chart

Use these steps to create a chart from data in

a worksheet range:

1. Select the data you want to plot. Include

any row or column labels that you want

to be part of the chart.

2. On the Insert tab → chart type buttons

→Charts group.

3. On the menu that appears → desired

sub-type. The chart appears in a floating

frame over the active sheet.

➢ Resizing a Chart

Use these steps to resize a chart:

1. Position the mouse pointer on a selection

handle on the border of the chart frame,

so the pointer becomes a double-headed

arrow. The selection handles on a chart

frame are located in the corners and in

the center of each side.

2. Drag the border to resize the chart’s

frame.



Adding and Removing Chart Elements

Each chart consists of a number of elements, and each element can be

selected and formatted separately. The figure below points out a number of

chart elements that you should be able to identify and select on a chart.

Chart area: The entire chart.

Plot area: The part of the chart on

which the data

Data point: A single point of plotted

data.

Data series The data representing one

row or column in the data

used to create the chart.

Chart title The overall label for the

chart, usually at the top of

the chart area.

Axis labels The text on the axes of the chart that shows the values.

Axis titles The text on the axes of the chart shows the meaning of the axis labels.

Data table An optional table that appears below the chart showing the values on

which it is based.



Changing the Chart Type

To change a chart’s type:

1. Select the chart.

2. Click the Change Chart Type

button on the Chart Tools Design

tab.

3. In the Change Chart Type dialog

box that appears, make your

selection of one of the types from

the list on the left and then

choose a sub-type from the

choices shown on the right. See

Figure below.



Formulas : are used to perform calculations in a worksheet. All formulas

must begin with an equal sign (=).

Formulas can consist of the following elements:

1. Constant values (such as 5 or 100).

2. Cell references (such as A1 or A1:A3).

3. Operators (such as + for addition or * for multiplication).

4. Functions (such as SUM or AVERAGE).



Operators: are symbols that represent specific mathematical operations.

Excel formulas support a variety of operators (see Table 3).

Arithmetic operators perform basic mathematical operations (such as

addition or subtraction) and return numeric results.

Comparison operators compare two values and return TRUE or FALSE.



When a formula contains more than one operator, Excel performs

calculations from left to right, based on the standard mathematical order of

operations.

You can change this order by using parentheses; calculations within

parentheses are performed first.

The basic order of operations is as

follows:

1. Percentage 

2. Exponentiation

3. Multiplication and division

4. Addition and subtraction     

5. Comparison



Most formulas are created using cell

references.

A cell reference : identifies a cell or a

range of cells in a worksheet.

There are three types of cell

references in Excel:

relative, absolute, and mixed

(see Table 4). These references

behave differently when a formula is

copied to other cells



Entering Formulas

You can create a simple formula by entering constant values or using cell 

references.

The advantage of using cell references in a formula : is that the formula 

automatically recalculates whenever the value in any cell referenced in the 

formula changes.

NOTE: To avoid typing mistakes, you can click a cell to insert its cell 

reference in a formula rather than typing its address.

To enter a formula:

1. Select the cell in which you want to

enter the formula.

2. Type an equal sign (=).

3. Enter the first value or cell reference.

4. Enter the desired operator.

5. Enter the next value or cell reference.

6. Repeat steps 4 and 5 as needed to

complete the formula

7. When finished, press the Enter key.



Functions: are predefined formulas that can be used to perform complex

calculations.

Excel includes hundreds of functions that you can use alone or in

combination with other formulas or functions.



Each function has its own syntax which specifies how it must be written.

The general syntax of a function is an

• equal sign (=).

• followed by the function name.

• opening parenthesis.

• the function arguments.

• closing parenthesis.

Function names (such as SUM and AVERAGE) describe the operation the

function performs.

Arguments specify the values or cell references the function uses when it

performs its operations. Some functions have no arguments or the

argument is optional.



There are a few rules to keep in mind when using functions:

1. Arguments must be entered in the order required by the function.

2. Arguments must be separated by commas.

3. Optional arguments must be placed after the required ones.

4. Parentheses are needed with every function, including functions that

have no arguments.

Using the AutoSum Button

The AutoSum button provides quick access

to the most commonly used functions (SUM,

AVERAGE, COUNT, MAX, and MIN).

It appears on both the Home tab and the

Formulas tab of the Ribbon.

The default action of the AutoSum button is

the SUM function;

you can access the other functions by

clicking the arrow on the button



Sum Numbers Using the AutoSum button:

1. Select a cell next to the numbers that you

want to sum.

2. On the Home tab, in the Editing group,

click the AutoSum button.

3. Excel automatically enters a formula that

uses the SUM function and suggests a

range to sum

4. Do one of the following:

1. If the suggested range is correct, press the Enter key to display the

result.

2. If the suggested range is incorrect, select the correct range, and then

press the Enter key to display the result.



Inserting Functions

Functions are organized into categories (Financial, Logical, Text, Date &

Time, Lookup & Reference, Math & Trig, etc.) based on their purpose

Each of the categories has a button in

the Function Library group on the

Formulas tab of the Ribbon.

• You can insert a function into a

formula by selecting it from one of

the function categories.

• If you are not sure which category

to choose, you can use the Insert

Function dialog box to browse

through the entire list of functions

and select the one you need.



insert a function:

1. Select the cell in which you want to enter the formula.

2. On the Formulas tab, in the Function Library group, click the Insert 

Function button.  

Or, 

click the Insert Function button on the Formula bar.

3. In the Insert Function dialog

box, search for a function or select

a category, select the desired

function, and then click the OK

button




