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Excel is Office 2010’s spreadsheet program. 

You use Excel to create, analyze, and manage 

documents called workbooks that contain text 

and numeric data. Workbooks can consist of 

simple lists (address books, club rosters, and 

collections) or complex calculations (book-

keeping systems, sales and expense tracking, 

engineering computations, and manufactur-

ing measurements). 

To get you started, this chapter presents the 

following essential Excel 2010 topics:

◆ Working with the Excel interface

◆ Understanding workbooks and worksheets

◆ Selecting cells and ranges

◆ Entering and editing data

◆ Reorganizing worksheets

◆ Filling cells

◆ Importing data

◆ Finding and replacing data

◆ Sorting data

◆ Naming cells and ranges

◆ Password-protecting workbooks

Getting 
Started with 
Excel 2010
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The Excel Interface
Before we jump into how to use Excel, take 

a moment to examine Figure 8.1 (below). It 

shows many of the Excel interface compo-

nents you’ll be using. You’ll note that some 

elements, such as the Ribbon, Quick Access 

Toolbar, and Backstage, can also be found in 

Word, PowerPoint, and Outlook.

Backstage. Click the File tab to go to the 

Backstage (Figure 8.2) to perform file-related 

activities, such as creating, opening, saving, 

and printing documents. Click Options to set 

Excel preferences. To open a document on 

which you’ve worked, click its filename in the 

Recent list. The Exit command can also be 

found in the Backstage.

File tab Recent Documents list

Exit Set preferences

Figure 8.2 The Backstage.

File tab Quick Access Toolbar Tab Group (Styles)

Ribbon

Column H

Row 7

Active cell (E6)Sheet tab bar Zoom controlsView controlsActive sheet

Close

Figure 8.1 Elements of the Excel 2010 interface. In this example, three workbooks are open and tiled.

Formula bar

Name 
box

Close
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Quick Access Toolbar. Common commands 

are found here, such as Save, Undo, and Redo.

Ribbon. The Ribbon is what Office now uses 

rather than menus. Similar commands and 

procedures are listed together on a tab, such 

as Insert or View. Within a tab, procedures 

are further divided into groups, based on sim-

ilarity of function. To perform a command, 

you switch to the appropriate tab by clicking 

its name and clicking the command’s icon.

Sheet tab bar. A workbook can contain 

multiple worksheets (or sheets). This area of 

the document window displays the names of 

all worksheets in the current workbook. To 

switch worksheets, click the sheet’s name.

Active sheet. This is the sheet that you’re 

currently viewing and/or editing.

Columns and rows. A worksheet is a grid of 

columns and rows. Columns are designated 

by letter and rows are numbered. A column

consists of all cells directly beneath a column 

letter. A row is the string of cells to the right of 

a row number.

Active cell. This is the currently selected cell 

(indicated by a heavy black border), named 

by combining the intersection of column and 

row. For example, E6 is in column E, row 6. 

The active cell name is shown in the name box, 

and the cell’s column letter and row number 

are highlighted.

Name box. The name box performs a variety 

of functions, including displaying the name of 

the active cell and creating names (a descrip-

tive name for a cell or range, such as SalesTax 

or Budget). Names are also referred to as range 

names and named ranges.

Formula bar. Data and formulas can be 

entered in the formula bar or directly into 

the active cell. The formula bar displays any 

formula or data contained in the active cell.

View controls. Click an icon to switch views 

(Figure 8.3). You can also change views by 

selecting the View tab and clicking an icon in 

the Workbook Views group. Use Normal or 

Page Layout view to work with or view your 

data. Full Screen view is useful when you want 

to view a worksheet at the largest possible 

size (without the Ribbon). Before you print, you 

can switch to Page Break Preview to examine 

and manually adjust the page breaks.

Zoom controls. You can change the current 

magnification by dragging the slider, clicking 

+ (increase) or – (decrease), or clicking the 

zoom percentage number.

Close. Workbooks and Excel each contain a 

close box that you can click to close an open 

workbook or to quit Excel, respectively.

Normal Page Break Preview

Page Layout

Figure 8.3 Click a 
View control icon to 
switch views.
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Workbooks and 
Worksheets
An Excel document consists of a single work-

book containing one or more worksheets. 

A worksheet (or sheet) has numbered rows 

and lettered columns that form a grid. The 

intersection of a row and column is called 

a cell (Figure 8.4). You can enter text data, 

numeric data, or formulas into the cells. Unlike 

in other programs you may have used, data 

doesn’t have to be entered from the top down, 

left to right. You can use any cells that you want, 

leaving blank rows and columns as best suits 

the data.

A setting in the General section of Excel 

Options (Figure 8.5) determines the initial 

number of worksheets in a new workbook. 

Depending on the data you’re entering and 

analyzing, you can ignore all worksheets but 

the first or use the others for a completely 

different type of data or related data. Because 

Excel lets you perform calculations across 

worksheets within a workbook, you can also 

use one sheet to consolidate the data in other 

sheets. For example, in a bookkeeping work-

book, you might collect each month’s data 

in a separate sheet and use another sheet to 

calculate annual figures, based on the data in 

the monthly sheets.

Worksheets are managed using the Sheet tab 

bar, found in the bottom-left corner of every 

workbook window (Figure 8.6). To make a 

different worksheet active, you click its name. 

You can add, delete, and change the order of 

the sheets. You can also rename a sheet to 

make it easier to identify.

To rename a worksheet:

◆ Right-click the tab of the worksheet you 

want to rename and choose Rename from 

the context menu (Figure 8.7). Type a 

new name and press e.

Figure 8.5 To set Excel preferences (such as the number 
of sheets per workbook), click the File tab to go to the 
Backstage and then click Options.

Sheets per workbook

NextPrev

Figure 8.6 You use the Sheet tab bar to make a 
worksheet active and to manage your worksheets. 
Each worksheet is represented by a named tab. Click 
the arrow icons to view additional sheets.

Insert WorksheetFirst Last

Active worksheet

Figure 8.4 A worksheet is a grid composed of 
rows and columns.

Row 3 Column B Cell B3

Figure 8.7 Right-click 
a worksheet’s tab to 
reveal this context 
menu.
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To delete a worksheet:

◆ Do either of the following:

▲ Right-click the tab of the worksheet 

you want to delete and choose Delete 

from the context menu (see Figure 8.7). 

▲ Switch to the Home tab, click the 

worksheet’s tab in the Sheet tab bar 

(to make the worksheet active), and 

choose Delete Sheet from the Delete 

drop-down menu in the Cells group 

(Figure 8.8).

If the worksheet contains data, a warning 

dialog box appears. Otherwise, the work-

sheet is immediately deleted.

To insert a new worksheet:

◆ Do one of the following:

▲ Click the Insert Worksheet icon in the 

Sheet tab bar (see Figure 8.6) or press 

s-.

▲ Right-click a worksheet name in the 

Sheet tab bar and choose Insert from 

the context menu. On the General tab 

of the Insert dialog box (Figure 8.9), 

select Worksheet and click OK.

▲ Switch to the Home tab, and choose 

Insert Sheet from the Insert drop-down 

menu in the Cells group. 

The new worksheet is appended to the 

end of the sheet list or inserted to the 

right of the currently selected sheet.

To change the order of worksheets:

◆ Drag the worksheet’s name to a new posi-

tion in the Sheet tab bar (see Figure 8.6). 

As you drag, a tiny triangle shows the 

sheet’s position. Release the mouse but-

ton to complete the move.

Creating New Workbooks

Although you can continue to add sheets 

to a workbook, you’ll want to create a new

workbook whenever you begin a project:

◆ To immediately create a new standard 

workbook, press cN.

◆ To create a specific type of workbook, 

click the File tab and click New. In the 

Available Templates gallery, select 

Blank workbook, a template, or New 

from existing. Click the Create button.

Figure 8.8 You can delete or insert 
sheets by choosing a command from 
the Delete or Insert icon.

Worksheet icon

Figure 8.9 To insert a new worksheet, ensure that 
Worksheet is selected and click OK.
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Cell and Range Selection
Whether you’re preparing to enter, edit, or 

format data, the first step is to select a cell or 

cell range. Following are some cell-selection 

techniques.

To select cells:

◆ Single cell. Do one of the following:

▲ Scroll to bring the cell into view and 

then click the cell.

▲ Press a navigation key (such as A, 

S, W, Z, t, st, e, or 

se) to move into the cell. See 

the Tips on the following page for other 

useful key combinations.

▲ On the Home tab, choose Go To (cG) 

from the Find & Select icon’s menu in 

the Editing group (Figure 8.10). In the 

Go To dialog box (Figure 8.11), select 

or type the cell address or name (if a 

name has been assigned to the cell). 

Click OK.

▲ Type the cell address, range, or name 

in the name box (Figure 8.12) and 

press e.

▲ To find a cell based on its contents, 

choose Find from the Find & Select 

icon’s drop-down menu (Figure 8.10). 

In the Find dialog box, enter the text, 

number, date, or time contained in 

the cell and click Find Next. When the 

desired cell is selected, click Close. See 

“Finding/Replacing Data,” later in this 

chapter, for additional options.

Figure 8.10 To go to a 
cell address or range, 
choose Go To from the 
Find & Select menu.

Figure 8.11 To specify a destination, enter an address, 
range, or name in the Reference text box or select a 
recently visited address, range, or name.

Figure 8.12 Type an address, range, or name in the 
name box.

Name box
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◆ Contiguous cell range. Do one of the 

following:

▲ Click a cell in any corner of the range 

(called the anchor) and drag to the 

opposite corner to select the additional 

cells (Figure 8.13).

▲ To select an entire column or row, click 

its letter or number (Figure 8.14).

▲ To select the entire worksheet, click 

the intersection of the column and 

row headings (Figure 8.14).

▲ On the Home tab, choose Go To (cG) 

from the Find & Select icon’s menu in 

the Editing group (see Figure 8.10). In 

the Go To dialog box (see Figure 8.11), 

enter the cell range in the form

start cell:end cell

such as a1:d4. If you’ve named the range 

(see “Naming Cells and Ranges,” later 

in this chapter), you can enter its name 

rather than the range. Click OK.

▲ Enter the cell range or its name in the 

name box (see Figure 8.12) and press 

e. 

◆ Noncontiguous cells and ranges. While 

pressing c, click or click-and-drag to 

select the cells, ranges, columns, and/or 

rows (Figure 8.15).

✔ Tips

■ If you need to regularly return to a cell or 

range, naming it will enable you to easily 

do so using the Go To command or the 

name box (see “Naming Cells and Ranges,” 

later in this chapter).

■ You can speed the entry of new data by 

preselecting the destination range. After 

each entry, press t or e to move 

through the range in left-to-right or  

top-to-bottom fashion, respectively.

■ Press cj to select the last cell in 

the active area of the worksheet, h to 

move to the first cell in the current row, or 

ch to move to cell A1.

■ Press c and an arrow key to move to 

the next filled cell in the specified direc-

tion. If there are no other filled cells, the 

first or last cell in the row or column will 

be selected.

Figure 8.13 To select a range, click a cell in one corner 
of the range and drag to the opposite corner.

Anchor (B2)

Click to select entire worksheet

Figure 8.14 To select a 
column or row, click its 
letter or number.

Selected column (A)

Figure 8.15 You can also select any combination of 
cells, ranges, rows, and columns (marked with light 
blue highlighting).
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Entering Data
A cell can contain one or more lines of text, 

a number, a date, a time, or a formula that 

results in one of these data types. To enter 

data into a cell, follow the instructions below. 

(Formulas are discussed in Chapter 10.)

To enter data into a cell:

1. Select the cell into which you want to enter 

data, making it the active cell.

You can select a cell by clicking in it. For 

other cell-selection methods, see the 

previous section.

2. Do one of the following:

▲ Text. Type or paste the text.

▲ Number. Type or paste the number.

▲ Date. Type a date in a recognizable 

format, such as 9-12-06, 09/12/2006, 

or 12-Sep-06. Date components must 

be separated by a slash (/) or hyphen 

(–) character.

▲ Time. Type a time in a recognizable 

format, such as 4:, 4:07, 4:07:53,

4:07 p, 4 pm, or 16:07. Time compo-

nents must be separated by a colon (:).

When a 12-hour time is entered, such 

as 10:43, it is assumed to be AM. To 

indicate PM, you must enter the time 

in military (24-hour) format or follow 

the time with p or pm, such as 6:15 p
or 6:15 pm. Morning times can option-

ally be followed by an a or am, such as 

7:15 a or 7:15 am.

3. To complete the entry, click another cell 

or press a navigation key, such as e or 

t. See Table 8.1 for options.

Changing the Behavior of e

Normally, pressing e when you finish 

entering data into a cell causes the cursor 

to move down, selecting the cell directly 

beneath the current cell. However, if you 

like, you can change the behavior of the 

e key:

1. Click the File tab. Click Options.

2. In the Excel Options dialog box, select 

the Advanced category.

3. Select a cursor-movement direction 

from the Direction drop-down list. 

(This is the first item in the Editing 

options section).

4. Click OK.

Using Entry AutoComplete

When you enter text or a combination of 

text and numbers into a cell, Excel checks 

the current column for matching entries. 

If one is found, Excel proposes it. To accept 

this AutoComplete entry, press e. To 

ignore it, continue typing.

Table 8.1

Keystrokes to Complete a Cell Entry
K e y s t r o k e D i r e c t i o n

t, S Right

st, A Left

e, Z Down

se, W Up
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✔ Tips

■ If a cell shows a string of # characters 

(#####), it means that the number in the 

cell is too large to display. To display the 

complete number, widen the column (see 

Chapter 9).

■ To enter multiple lines of text, numbers, 

dates, or times into a cell (Figure 8.16), 

press ae to insert a line break 

between each pair of lines.

■ To enter today’s date into a cell, press 

c;. To enter the current time, press 

cs;.

■ If you want the data to display differently, 

select the cell and apply formatting (see 

Chapter 9). The current formatting for the 

active cell is shown in the Number Format 

box in the Number group on the Home tab 

(Figure 8.17).

■ If you enter a number that begins with one 

or more zeros, Excel discards the zeros. 

This presents a problem with some ZIP 

codes, for example. To force Excel to retain 

leading zeros, choose Text from the 

Number Format menu (Figure 8.18) in 

the Number group before entering the data.

■ Excel distinguishes between data display

(determined by formatting) and what is 

stored. When performing calculations, 

Excel uses the stored data, regardless of 

what’s shown in the cells. For example, 

when calculating a sales tax of 7.75% on 

a $12.50 purchase, the result is 0.9675. 

When formatted as Currency, the number 

displays as $0.97, the result rounded 

to two decimal places. If you create a 

formula in another cell that adds the 

sale amount ($12.48) to the sales tax, the 

result is 13.46875—not $13.47.

Figure 8.16 You can force line 
breaks within a cell.

Figure 8.17 You can see the 
formatting for the active cell 
in the Number group on the 
Home tab.

Current format

Figure 8.18 You can 
format any data as text 
by choosing Text from 
the Number Format 
drop-down menu.

Number Format menu

  



ptg

Chapter 8

164

E
d

i
t

i
n

g
 D

a
t
a

Editing Data
As you create and work with a worksheet, 

you can correct errors, update data with new 

values, and revise formulas.

To edit the contents of a cell:

1. Select the cell whose contents you want 

to change.

2. You can edit in the formula bar or in the 

cell itself. To set the text insertion mark 

and begin editing, click in the formula bar 

or double-click in the cell.

If the cell contains a formula, the formula 

appears (Figure 8.19). Otherwise, the 

data is shown.

3. Make the desired changes.

4. To finish the edits, do one of the following:

▲ Press a navigation key, such as e, 

to move to another cell (see Table 8.1). 

▲ Click another cell.

▲ Click the check mark (✔) icon in the 

formula bar (Figure 8.19).

✔ Tips

■ You can use the same editing techniques 

you use when modifying other kinds of 

Windows documents. For example, press 

B to delete the character to the 

left, press d or D to delete the 

character to the right, or press any of these 

keys to delete selected text. To replace a 

string, select it and type the replacement 

or delete the string and then type.

■ The cursor keys are active while editing. 

Press A or S to move one character in 

the desired direction; press cA or 

cS to move one string at a time.

■ To rearrange data within a cell, you can 

cut (cX) selected data, set the text 

insertion mark where you want to move 

the data, and then paste (cV).

Figure 8.19 When you select a cell (top), its contents 
are shown in the formula bar. When you set the text 
insertion mark for editing (bottom), the result is 
replaced in the cell by the actual formula.

Selected cell Cell contentsCell address

Formula
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Reorganizing a Worksheet
In addition to editing cell contents, you can 

rearrange the data. You can move cells to 

other locations, add or delete cells (automati-

cally shifting the affected surrounding cells), 

and insert or delete rows and columns.

To move cells to another location:

1. Select the cell or range you want to move.

2. Do one of the following:

▲ Cut the cell/range by pressing cX

or by clicking the Cut icon in the 

Clipboard group on the Home tab 

(Figure 8.20). Select the destination 

cell or the cell in the upper-left corner 

of the destination range. Press e, 

press cV, or click the Paste icon in 

the Clipboard group.

▲ Move the cursor over the border of the 

selected cell or range (Figure 8.21). 

Drag the selected cell to the destina-

tion cell or the selected range to the cell 

that will serve as the upper-left corner 

of the destination range. Release the 

mouse button to complete the move.

Neither procedure deletes the original 

cells. Their data is simply moved to the 

new location.

✔ Tips

■ Whether performed by cut-and-paste or 

drag-and-drop, cell/range moves are 

destructive. If you select a destination that 

already contains data, the old data will be 

replaced by the moved data. If this happens 

unintentionally, immediately click the 

Undo icon in the Quick Access Toolbar 

(Figure 8.22) or press cZ.

■ To move data between worksheets, use 

cut-and-paste.

Cut

Copy

Paste

Figure 8.20 The Cut, Copy, and 
Paste commands can be found 
in the Clipboard group.

Undo Redo

Figure 8.22 To undo your last action, 
click the Undo icon. To undo multiple 
actions, choose an action from the 
Undo icon’s drop-down menu.

Figure 8.21 When the cursor changes 
to this symbol, you can drag the 
selected cell(s) to a new location.
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To copy cells to another location:

1. Select the cell or range you want to copy.

2. Do one of the following:

▲ Copy the cell/range by pressing cC

or by clicking the Copy icon in the 

Clipboard group on the Home tab (see 

Figure 8.20). Select the destination cell 

or the cell in the upper-left corner of the 

destination range. Press e, press 

cV, or click the Paste icon in the 

Clipboard group on the Home tab.

▲ While pressing c, move the cursor 

over the border of the selected cell 

or range. A tiny plus symbol is added 

to the cursor (Figure 8.23). Drag the 

cell/range to the destination cell or to 

the cell in the upper-left corner of the 

destination range.

✔ Tip

■ Rather than just clicking Paste, you can 

click the arrow beneath Paste to reveal a 

gallery of Paste options (Figure 8.24). If 

you rest the cursor on an option, a ToolTip 

explains the option and a preview appears 

on the worksheet.

To insert cells:

1. Select the cell or range where you want to 

insert new, blank cells.

2. Do one of the following:

▲ On the Home tab, click the Insert icon 

in the Cells group and choose Insert 

Cells (Figure 8.25).

▲ Right-click the cell or range and choose 

Insert from the context menu.

3. In the Insert dialog box (Figure 8.26), 

select Shift cells right or Shift cells down, 

and then click OK.

Cells affected by the insertion are shifted 

to make room for the inserted cell(s).

Copy cursor

Figure 8.23 You can copy 
material to a new location 
by c-dragging.

Figure 8.24 You can choose 
advanced Paste options 
from this gallery.

Figure 8.26 When inserting new cells, 
you must specify how surrounding cells 
will be affected.

Figure 8.25 Choose Insert Cells 
from the Insert menu.
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To delete cells:

1. Select the cell or range you want to delete.

2. Do one of the following:

▲ On the Home tab, click the Delete icon 

in the Cells group and choose Delete 

Cells from the drop-down menu.

▲ Right-click the cell or range and choose 

Delete from the context menu that 

appears (Figure 8.27).

3. In the Delete dialog box (Figure 8.28), 

select Shift cells left or Shift cells up, and 

then click OK.

Surrounding cells affected by the deletion 

are shifted to close the space left by the 

deleted cell(s).

To insert a row:

1. Select the row where you want to insert a 

new row.

2. Do one of the following:

▲ On the Home tab, click the Insert icon 

in the Cells group (see Figure 8.25). 

▲ Right-click any cell in the selected row 

and choose Insert from the context 

menu (Figure 8.27).

The new row appears. The selected row 

and all those beneath it shift down one.

✔ Tips

■ You can also select a single cell in the row 

where you want to insert a new row. 

However, you must then choose Insert 

Sheet Rows from the Insert icon’s menu 

(see Figure 8.25) or select Entire row in 

the Insert dialog box (see Figure 8.26).

■ To insert multiple rows, select as many 

rows as you want new rows and click the 

Insert icon. You can also right-click any 

cell in the selected rows and choose Insert 

from the context menu (Figure 8.27).

Figure 8.28 Specify how neighboring 
cells should shift in response to the cell 
or range deletion.

Figure 8.27 Right-click a selected cell or 
range, and then choose Delete.
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To insert a column:

1. Select the column where you want to insert 

a new column (Figure 8.29, top).

2. Do either of the following:

▲ On the Home tab, click the Insert icon 

in the Cells group (see Figure 8.25).

▲ Right-click any cell in the selected 

column and choose Insert from the 

context menu (see Figure 8.27).

The new column appears (Figure 8.29, 

bottom). Other columns affected by the 

insertion shift to the right.

✔ Tips

■ You can also select a single cell in the 

column where you want to insert the new 

column. However, you must then choose 

Insert Sheet Columns from the Insert 

icon’s menu or select Entire column in the 

Insert dialog box (see Figure 8.26).

■ You can insert multiple columns by select-

ing the columns (or a cell in each column) 

where you want to add the new columns 

in Step 1 (Figure 8.30). 

To delete a row:

1. Select the row that you want to delete.

2. Do one of the following:

▲ On the Home tab, click the Delete icon 

in the Cells group.

▲ Right-click any cell in the selected row 

and choose Delete (see Figure 8.27).

The row is deleted. Other rows that are 

affected by the deletion shift up to close 

the space.

Selected column (E)

Figure 8.29 Suppose that you need to record a fourth 
test. When you select column E and issue the Insert 
command, the original column E shifts to the right to 
become column F.

Modified worksheet Inserted column

Original worksheet

Figure 8.30 You can also begin a column or row 
insertion by selecting single cells or a range. In this 
example, to insert new columns in C and D, it’s 
sufficient to select any pair of cells that spans both 
columns.

Selected cells in columns C and D
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✔ Tips

■ You can also select a cell in the row you 

want to delete. However, you must then 

choose Delete Sheet Rows from the Delete 

icon or select Entire row in the Delete 

dialog box (see Figure 8.28).

■ To delete multiple rows, select the rows 

(or a cell in each row) that you want to 

delete in Step 1.

To delete a column:

1. Select the column that you want to delete.

2. Do one of the following:

▲ On the Home tab, click the Delete icon 

in the Cells group.

▲ Right-click any cell in the selected 

column and choose Delete from the 

context menu (see Figure 8.27).

The column is deleted, and all columns to 

its right shift to the left.

✔ Tips

■ You can also select a single cell in the 

column you want to delete. However, you 

must then choose Delete Sheet Columns 

from the Delete icon or select Entire  

column in the Delete dialog box (see 

Figure 8.28).

■ To delete multiple columns, select the 

columns (or a cell in each column) that 

you want to delete in Step 1. 

■ Deleting cells, rows, or columns isn’t the 

same as clearing their contents. To clear 

selected cells, switch to the Home tab and 

choose a command from the Clear icon’s 

menu in the Editing group.

■ Deleting cells, rows, and columns are 

destructive processes. Because every row 

and column extends to the end or bottom 

of the worksheet, be sure not to acciden-

tally delete data that isn’t in view.

Insertion and Deletion 
Considerations

When inserting or deleting cells, rows, or 

columns, you must consider the impact 

on your worksheet. Insertions and dele-

tions often cause other data to move:

◆ When you insert a cell, the current cell 

must either move to the right or down. 

Other cells to the right or below the 

inserted cell will also shift to the right 

or down. 

◆ When you delete a cell, all cells directly 

below or to the right of the deleted cell 

must shift up or left to fill the hole cre-

ated by the deletion.

◆ When you insert a new row, the current 

row automatically moves down to make 

room for the new row. Rows below the 

current row also move down one row. 

◆ When you insert a column, the current 

column and all columns to its right 

shift one column to the right.

The impact of an insertion or deletion on 

data elsewhere in the worksheet must be 

considered. For instance, if a worksheet 

contains a single data array or table, such 

as an address book, inserting or deleting a 

row or column will have little impact. And 

if you discover that you entered the same 

data in two cells in a row (causing the row 

to have an extra entry), deleting a duplicate 

and choosing Shift cells left quickly fixes 

the problem.

But when a worksheet is complex and has 

multiple data arrays, an insertion or dele-

tion is liable to create problems elsewhere 

in the sheet. If this is the case, the safest 

approach may be to manually rearrange 

the data rather than make insertions or 

deletions.
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Filling Cells
Two situations occur in worksheet creation 

that can be simplified using the Fill feature:

◆ You have a text constant, numeric constant, 

or formula that you want to repeat many 

times in the current row or column.

◆ You have or are creating a series of cell 

entries in the current row or column that 

you want to extend.

To fill adjacent cells with a constant:

◆ Do either of the following:

▲ Select the cell that contains the text or 

numeric constant. Move the cursor 

over the lower-right corner of the cell, 

click the fill handle (Figure 8.31), and 

drag in the direction that you want to 

fill (Figure 8.32).

▲ Select the cell with the text or numeric 

constant and the cells you want to fill. 

On the Home tab, choose the fill 

direction from the Fill icon’s menu in 

the Editing group (Figure 8.33). 

The cells fill with the constant.

✔ Tips

■ To duplicate a cell regardless of the type 

of data it contains (text, number, date, 

or time), select the cell immediately to 

the right or below it and press cR or 

cD, respectively.

■ You can perform a drag fill in any direction: 

right, left, down, or up.
Figure 8.33 You can also perform a 
fill by choosing a direction from the 
Fill menu. 

Fill icon

Fill handle

Cursor

Figure 8.31 You can 
fill cells by dragging.

Figure 8.32 Drag to select 
the cells you want to fill.

Fill preview

Selected cells
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To fill adjacent cells with a formula:

◆ Do either of the following:

▲ Select the cell with the formula. 

Click the fill handle and drag in the 

direction that you want to fill (see 

Figures 8.31–8.32).

▲ Select the cell with the formula, as well 

as the cells you want to fill (Figure 8.34). 

On the Home tab, click the Fill icon in 

the Editing group and choose a fill 

direction: Down, Right, Up, or Left  

(see Figure 8.33).

The cells fill with the formula. Note that 

relative cell references (see Chapter 10) in 

the formula are automatically adjusted in 

the filled cells.

To continue a series into adjacent cells:

1. If the series doesn’t already exist, begin it 

by typing at least two adjacent entries in a 

row or column.

For example, for invoice numbers starting 

with 1050, you would enter 1050 and 1051. 

For company divisions, you could type 

Div1 and Div2, Div. 1 and Div. 2, or 

Division 1 and Division 2. For days of the 

week, you could enter Sunday and Monday
or Sun and Mon.

2. Select two or more adjacent cells contain-

ing members of the series. Drag the fill 

handle of the rightmost or lowest cell in the 

direction you want to fill (Figure 8.35). As 

you drag, Excel shows the data each cell 

will contain.

Series data fills the cells.

✔ Tips

■ When expanding certain series such as 

dates, an Auto Fill Options icon appears 

(Figure 8.36). Click it to set a fill specifi-

cation for the series. If you drag-extend 

the series using the right mouse button, 

similar options appear in a context menu.

■ When continuing a series, select enough 

data to enable Excel to discern the nature 

of the series. In some cases, such as a day 

name, month name, or numbered text 

(Quarter 1, Score 1, or Team 1, for example), 

one item may be sufficient.

■ For more complex series (especially 

numerical ones), you can choose Series 

from the Fill icon’s menu (Figure 8.33) 

and set options in the Series dialog box. 

In general, however, you’ll be happier if 

one of the previously described methods 

works. The Series dialog box can be seri-

ously confusing.

Figure 8.34 Select the cell that contains the formula 
(E2), as well as the cells you want to fill (E3:E7).

Formula in E2

Selected cells

Figure 8.35 This series expands in 14-day increments.

Figure 8.36 The Auto Fill Options menu.

Auto Fill Options icon
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Importing Data
You don’t have to manually enter the data in 

every worksheet. If the data exists elsewhere, 

such as in a table on the Web, in another pro-

gram, or in a properly formatted text file, you 

can import the data into a new or existing 

worksheet. Following are examples of common 

data-importing scenarios.

To import data from a Web table:

1. On the Data tab, click the From Web icon 

in the Get External Data group.

A New Web Query dialog box appears.

2. In the Address box (Figure 8.37), type 

or paste the URL for the Web page that 

contains the data and click Go. (If you 

recently viewed the page, you may be able 

to select its URL from the Address box’s 

drop-down menu.)

The Web page is fetched from the Internet 

and displayed in the dialog box.

3. Each table on the page is marked with 

an arrow enclosed in a yellow box. Click 

the box for each table that you want to 

import (Figure 8.38) and click Import.

The Import Data dialog box appears 

(Figure 8.39), asking where you want to 

import the data. By default, the active cell 

on the current worksheet is proposed.

4. Select one of the following:

▲ Existing worksheet. Specify the start-

ing cell to receive the imported data 

by typing its address in the box or by 

clicking the cell on the worksheet.

▲ New worksheet. Excel will create a 

new worksheet in the current work-

book and import the data into a range 

beginning with cell A1.

5. Click OK.

Each table you selected in Step 3 is 

imported (Figure 8.40).

Figure 8.37 Enter a page address in the Address box 
at the top of the New Web Query dialog box.

Select a recently viewed pagePage address

Figure 8.39 Specify a destination for the 
imported data and click OK.

Figure 8.40 Here’s the imported data (after applying 
text wrap to column B and formatting the data set as 
a table).

Figure 8.38 Click the icon beside each table that you 
want to import.

Table-selection icon OptionsGoAddress
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✔ Tips

■ After entering a URL in the Address box 

(see Figures 8.37–8.38), you can interact 

with the fetched page. You can follow links 

by clicking them; enter your user name 

and password (for sites that require a login); 

and click buttons at the top of the dialog 

box to go backward or forward, refresh the 

page, or stop.

■ To import data with its original formatting 

intact, click the Options button at the top 

of the New Web Query dialog box (see 

Figure 8.38). In the Formatting section 

of the Web Query Options dialog box 

(Figure 8.41), select Rich text formatting 

only or Full HTML formatting, and then 

click OK.

■ Another way to retain a Web table’s 

formatting is to open the page in a Web 

browser, drag to select the table, and copy 

(cC) the data. Select a destination cell 

in the worksheet and then paste (cV). 

See Figure 8.42 for an example.

■ Additional options for a Web import can 

be viewed by clicking the Properties 

button in the Import Data dialog box (see 

Figure 8.39). 

Figure 8.41 To retain formatting, select a Formatting 
option in the Web Query Options dialog box.

Figure 8.42 When moved into a worksheet via copy-and-paste, a Web table retains its fonts, styles, colors, and cell 
shadings. This can also be achieved by selecting Full HTML formatting in the Web Query Options dialog box.
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To export data from another program 
in Excel format:

1. Open the document in its creating appli-

cation, such as a database, a spreadsheet, 

or an address book utility. 

2. Optional: Select the records (or portion 

of the document) that you want to use in 

Excel. If possible, rearrange the data fields 

to match the order in which you want them 

to appear in the worksheet. 

3. Use the program’s Export, Save As, or 

equivalent command to save a copy of the 

data as an Excel (.xls or .xlsx) worksheet file 

(Figure 8.43).

Note, however, that not all programs offer 

this capability.

4. In Excel, click the File tab to go to the 

Backstage, click Open, and open the 

exported data file (Figure 8.44).

Alternatively, you may be able to open the 

file by simply clicking or double-clicking it.

✔ Tips

■ The exported data may require cleanup in 

Excel. For instance, you may need to add 

or edit column heads, rearrange the col-

umns and change their widths, and add 

appropriate number and date formatting.

 ■ Most Export and Save As procedures do 

not export formulas. In general, the results

of such calculations are exported. If you 

intend to work with and extend the data 

in Excel, you’ll probably want to recreate 

the formulas. On the other hand, if the 

reason you exported the data was so you 

could use Excel to analyze or chart it, 

working with the export as is may suffice. 

Figure 8.43 In FileMaker Pro (Mac version shown), any 
database can be exported as an Excel file.

Export filename

Excel as the file type

Figure 8.44 Here’s the exported database opened in 
Excel 2010.
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To export data from another program 
as a text file:

1. Open the document in its creating appli-

cation, such as a database, spreadsheet, 

or address book utility. 

2. Optional: Select the records (or portion 

of the document) that you want to use in 

Excel. If possible, rearrange the data fields 

to match the order in which you want them 

to appear in the worksheet. 

3. Use the program’s Export, Save As, or 

equivalent command to save a copy of 

the data as a tab-delimited or a comma-

delimited text file.

The program may refer to these file types 

as tab-separated and comma-separated.

4. In Excel, switch to the Data tab and click 

the From Text icon in the Get External 

Data group.

The Import Text File dialog box appears 

(Figure 8.45).

5. Navigate to the drive/folder that contains 

the exported data file. 

6. Do one of the following:

▲ If the exported data file appears in 

the file list, select it and click Import 

(or Open). 

▲ If the export file is not present in the 

file list, select All Files from the file-type 

list (Figure 8.45). Select the export file in 

the file list and click Import (or Open).

7. In Step 1 of the Text Import Wizard 

(Figure 8.46), ensure that Delimited is 

selected. Examine the data preview in 

the bottom of the window, verifying that 

it is the correct file and displays properly. 

Click Next to continue.

continues on next page

Figure 8.45 Select the exported data file from the files 
listed in the Import Text File dialog box (Windows 7 
shown).

Display these file types

Figure 8.46 Examine the data in the preview area 
and ensure that the correct field-export description 
is selected.

Field-arrangement description

Data preview
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8. In Step 2 of the wizard (Figure 8.47), 

ensure that the correct data delimiter is 

checked. (Data in the Data preview sec-

tion will be correctly divided into fields 

when the right delimiter is selected.) Click 

Next to continue.

9. Optional: In Step 3 of the wizard 

(Figure 8.48), you can specify a format 

for the data in each field. Select the field 

in the Data preview and click the appro-

priate Column data format radio button. 

Note that General format is appropriate 

for most types of data, including dates.

10. Optional: If you decide not to import cer-

tain fields, select each field in the Data 

preview and click the Do not import 

column (skip) radio button. 

11. Click Finish.

The Import Data dialog box appears (see 

Figure 8.39).

12. Do one of the following:

▲ To open the file in the current work-

sheet, select Existing worksheet and 

specify the starting cell in which to 

receive the data.

▲ To open the file in a new sheet in the 

workbook, select New worksheet.

13. Click OK to import the data into Excel.

✔ Tips

■ Excel can also import data from files with 

fixed-width fields (see Figure 8.46). Some 

programs, especially very old database 

applications, store data in fixed-width 

fields. When originally creating the file, 

you had to specify the maximum number 

of characters for each field. When you 

entered data but failed to use the allotted 

characters for a field, the program simply 

padded the field with spaces. 

Figure 8.48 Click each column in the Data preview 
area to ensure that an appropriate format is assigned.

■ Excel can also open comma-separated 

value (CSV) files directly, bypassing the 

Text Import Wizard. Instead of clicking the 

From Text icon in Step 4, click the File tab, 

click Open, set the file type to Text Files, 

and open the .csv file.

Select the delimiter character

Data preview

Figure 8.47 Select the delimiter character that was 
used to separate fields in the export file.
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Finding/Replacing Data
Although you can scroll through a worksheet 

to find a particular string (such as a label, 

data, a cell reference, or a formula element), 

you may be able to use the Find feature to 

quickly locate the item. You can optionally 

replace any found string with another string.

To perform a Find:

1. To restrict the search to a range, select the 

range. Otherwise, click the cell in which 

you’d like to begin the search.

2. On the Home tab, choose Find from the 

Find & Select icon’s drop-down menu in 

the Editing group (Figure 8.49) or press 

cF.

The Find and Replace dialog box appears 

(Figure 8.50).

3. Enter a search string in the Find what box.

4. Optional: If the additional search options 

aren’t visible, click the Options button to 

display them. You can set any combination 

of the following options:

▲ Within. Indicate whether you want to 

search within the current worksheet or 

all sheets in the workbook.

▲ Search. Specify whether the search 

will proceed across rows and down 

(By Rows) or down columns and 

across (By Columns).

▲ Look in. Specify the cells to be 

searched. Choose Formulas to con-

sider all cells, Values to search all cells 

except those containing a formula, or 

Comments to search only within com-

ments (ignoring cell contents).

▲ Match case. When this option is 

enabled, capitalization within a cell 

must match that of the search string.

continues on next page

Show/hide options

Figure 8.50 The Find and Replace dialog box (with 
options displayed).

Figure 8.49 Find, Replace, Go To, and 
Select commands can be chosen from 
the Find & Select menu.

  



ptg

Chapter 8

178

F
i
n

d
i
n

g
/

R
e

p
l

a
c

i
n

g
 D

a
t
a

▲ Match entire cell contents. Cell con-

tents must exactly match the search 

string. For example, searching for 

Microsoft will find cells that contain

Microsoft but ignore Microsoft 
Corporation.

Unless you check this option, a match 

can be found anywhere within a cell. 

For instance, searching for 3 would 

match 3, 7.23, 1:37, 5/3/2005, A32, and 

=B7-G23.

▲ Format. To include formatting in the 

Find criteria, click the Format button 

and choose one of these options from 

the drop-down menu (Figure 8.51): 

Format. Specify format settings in the 

Find Format dialog box. 

Choose Format From Cell. Using the 

eyedropper cursor, click a cell whose 

formatting will serve as the criterion.

Clear Find Format. Choose this option 

to remove previously chosen format-

ting as a criterion.

5. Do one of the following:

▲ Click Find Next to go to the first match 

(if any are present). Continue clicking 

Find Next to step through the matches.

▲ Click Find All to display a list of all 

matches in the bottom of the dialog box 

(Figure 8.52). Click any match to go to 

that cell.

6. When you’re finished, click Close.

✔ Tips

■ To perform a simple search, hide the 

options in the Find and Replace dialog 

box by clicking the Options button, and 

then click Close. Issue the Find command 

again, enter a search string in the Find and 

Replace dialog box, and click Find Next or 

Find All. The search is performed by rows, 

identifies partial matches, and searches in 

every cell.

■ Another way to limit the scope of a Find is 

to first choose a selection command from 

the Find & Select icon’s drop-down menu 

(see Figure 8.49).

■ The Find and Replace procedures support 

the use of wildcards as criteria. Use the 

? wildcard to replace a single character 

and * to replace multiple (or 0) characters. 

For example, you could enter ba?k to find 

back, balk, bank, bark, and bask. Enter 

John* to find John, Johns, Johnson, and 

Johnston.

Figure 8.51 To add or remove formatting as 
a match criterion, click the Format button 
and choose a command.

Find All results

Figure 8.52 When you click Find All, matching cells 
are displayed in a scrolling list.
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To perform a Find/Replace:

1. To restrict the Find/Replace to a range, 

select the range. Otherwise, click the cell 

in which you’d like to start the search.

2. Open the Find and Replace dialog box by 

doing one of the following:

▲ On the Home tab, choose Replace 

from the Find & Select icon’s menu in 

the Editing group (see Figure 8.49) or 

press cH.

▲ On the Home tab, choose Find from the 

Find & Select icon’s drop-down menu 

in the Editing group (see Figure 8.49) 

or press cF. In the Find and Replace 

dialog box, click the Replace tab.

The Find and Replace dialog box is ready 

to receive search criteria (Figure 8.53).

3. Enter criteria by performing Steps 3–4 of 

the previous procedure. Enter a replace-

ment string in the Replace with box.

Note that Format can be set separately for 

the Find and Replace strings.

4. Do one of the following:

▲ To make the replacement decision 

individually for each match, click Find 

Next. Excel moves to the first match, if 

one is found. 

To replace the matching contents with 

the Replace with string, click Replace. 

Or to ignore the current match, click 

Find Next. Excel selects the next match-

ing cell. Repeat for each additional 

match.

▲ To simultaneously perform all replace-

ments, click Find All. Review the 

matches in the bottom of the dialog 

box and click Replace All. Click OK 

to close the dialog box and view the 

results of the Replace All.

5. Click Close.

✔ Tips

■ When the Find and Replace dialog box is 

open, you can switch freely between its 

modes by clicking the Find or the Replace 

tab. In fact, a Replace is frequently preceded 

by a Find, allowing you to first determine 

if there is anything to replace.

■ When making a replacement without 

checking Match entire cell contents, you 

will only replace the matching portion 

of a cell’s contents. For example, if you 

search for corp with the intent of replac-

ing it with corporation, scorpio will be 

replaced by scorporationio.

■ You can also use the Find and Replace 

dialog box to replace formatting without 

changing cell contents. Leave the Find 

what and Replace with boxes empty, and 

set Format options for both.

Figure 8.53 The Find and Replace dialog box with 
options hidden (top) and displayed (bottom).

Show/hide other options
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Sorting Data
To maintain data in a particular order 

(arranging entries in an address list by last 

name, phone number, or ZIP code, for exam-

ple), you can sort the data. You can sort any 

column in ascending or descending order, 

based on the contents of that column. If 

surrounding data is related to the data in the 

selected column (created as records), data 

in the adjacent columns can also be reorga-

nized to match that of the sorted column. 

To sort a column or data array:

1. Select the column you want to sort or by 

which you want to sort all surrounding 

data (Figure 8.54).

2. On the Home tab, click the Sort & Filter 

icon and choose a sort order, such as Sort 

A to Z, Sort Smallest to Largest, or Sort 

Oldest to Newest (Figure 8.55).

The options presented vary with the type 

of data in the selected column. If there are 

no adjacent columns on either side of the 

selected column, the column is sorted as 

specified.

3. Otherwise, if columns are adjacent to the 

selected column, the Sort Warning dialog 

box appears (Figure 8.56). Select one of 

these options:

▲ Expand the selection. Treat all con-

tiguous columns (on both sides of the 

selected column) as a data array.

▲ Continue with the current selection. 

Sort only the selected column, leaving 

any surrounding columns unchanged.

4. Click Sort to sort the data as specified.

Selected column

Figure 8.54 Start by selecting the column to sort.

Figure 8.55 Choose a sort command from 
the Sort & Filter menu.

Figure 8.56 To clarify your selection, indicate whether 
you want to sort the entire array or only the selected 
column.
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✔ Tips

■ To perform a more complex sort, choose 

Custom Sort from the Sort & Filter 

drop-down menu, and then set options in 

the Sort dialog box (Figure 8.57). Options 

include sorting on multiple columns (last 

name and first name, for example) and 

performing sorts based on cell or font color. 

To sort by rows (rather than by columns) 

or to use letter case in a sort, click the 

Options button in the Sort dialog box. Set 

options in the Sort Options dialog box 

(Figure 8.58) and then click OK to return 

to the Sort dialog box.

■ To really simplify the process of sorting a 

data array, consider defining the array as 

a table (see Chapter 11).

■ A sort can also be initiated using other cell 

and range selections: 

▲ If you select only a cell in the column 

you want to sort or by which you want 

to sort all surrounding data, the sort 

is performed immediately. If there are 

no adjacent columns, the column is 

sorted as specified. If there are adja-

cent columns, they are treated as an 

array. The entire array is sorted based 

on the data in the sort column.

▲ If you select a range that contains 

multiple columns prior to choosing 

a Sort command, the selected range 

will be sorted. The first column is 

automatically treated as the sort-by 

column. Other adjacent columns and 

cells outside the selected range are not 

changed.

■ Another way to analyze a data array is to 

filter it by hiding selected rows (records) 

or showing only those that satisfy a 

criterion, such as after 5/1/10: 

▲ To add filter capabilities to a single 

column (whether or not it’s part of an 

array), select the column, switch to the 

Home tab, click the Sort & Filter icon 

in the Editing group, and choose Filter 

from the drop-down menu. 

▲ To add filter capabilities to all columns 

in a data array, select the entire array 

or any individual cell in the array, and 

choose Filter from the Sort & Filter 

icon’s drop-down menu.

See Chapter 11 for more information about 

applying and using filters.

Figure 8.57 Choose Custom Sort to sort on multiple 
fields. In this example, a medical expenses data array 
is sorted on Service Type and then—within Service 
Type—by Description.

Figure 8.58 Set additional options 
in the Sort Options dialog box.

Consider letter case

Sort rows

Sort columns
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Naming Cells and Ranges
In addition to referencing cells and ranges 

by their addresses (such as G17 and A1:D8), 

you can assign names to them. There are two 

reasons to name certain cells and ranges:

◆ It’s easier to find important data in the 

Go To dialog box (see Figure 8.11) using a 

name because you don’t have to memorize 

cell or range addresses.

◆ A name can be used in formulas (see 

Chapter 10) as a replacement for a cell 

address or range, making the formula 

easier to create and understand, such as 

=Total*Tax_Pct.

A name can contain 255 characters: letters, 

numbers, periods, and underscores (_). The 

first character must be a letter, underscore, or 

backslash (\). Although names cannot contain 

spaces, you can represent a space with a period 

or underscore, such as Div_1 or Div.1. Names 

aren’t case-sensitive, so Budget, BUDGET, and 

budget are considered to be the same name.

To name a cell or range:

1. Select the cell or range that you want to 

name (Figure 8.59).

2. Do either of the following:

▲ Enter the name in the name box 

(Figure 8.60) and press e.

▲ On the Formulas tab, click the Define 

Name icon in the Defined Names 

group or choose Define Name from 

the Define Name menu. Complete the 

information in the New Name dialog 

box (Figure 8.61) and click OK.

Figure 8.60 Enter a name for the selected cell or 
range in the name box.

Figure 8.59 Select the cell or range to be named. (In 
this example, column G is selected.)

Figure 8.61 Creating a name in the New Name dialog 
box allows you to set a scope for the name (worksheet 
or workbook), add an optional comment, and edit the 
cell or range reference.
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✔ Tips

■ In previous versions of Excel and in other 

spreadsheets, a name was often referred 

to as a range name or named range. 

■ If Excel can associate a row or column 

label with the selected range, it will propose 

the label as the name in the New Name 

dialog box.

■ Every created name has a scope; it can 

be a specific worksheet or all worksheets 

in the current workbook. When a name 

is created in the name box, its scope is 

automatically set to the workbook. If you 

create the name in the New Name dialog 

box (see Figure 8.61), you can set either as 

the scope.

■ Tables can also be named. In fact, when 

you create a table, a default name is 

assigned to it, based on the number of 

tables already in the worksheet (Table1, 

Table2, and so on). 

To rename, delete, or modify a name:

1. On the Formulas tab, click the Name 

Manager icon in the Defined Names group.

The Name Manager dialog box appears 

(Figure 8.62).

2. Select a name from the Name list, and click 

one of these buttons:

▲ Delete. Delete the name. To confirm 

the deletion, click OK in the dialog box 

that appears. 

▲ Edit. Change the name, add a com-

ment (or edit the current comment), 

or change the cell or range to which 

the name refers (Figure 8.63). Click 

OK to close the dialog box, saving your 

changes.

3. Click Close to dismiss the Name Manager 

dialog box.

✔ Tip

■ To limit the names listed in the Name 

Manager dialog box to defined names, 

table names, names scoped to the work-

sheet or the workbook, or ones with or 

without errors, click the Filter button and 

choose an option from the drop-down 

menu (Figure 8.62).

Filter the Name list

Figure 8.62 You can create, rename, edit, and delete 
names in the Name Manager dialog box.

Figure 8.63 Use the Edit Name dialog box to rename 
a name, add a comment, or change the address or 
range to which the name refers.
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Password-Protecting 
Workbooks
Excel provides a variety of tools for protect-

ing data. One that you are likely to use is that 

of adding password protection to a workbook 

(requiring a password to open and/or modify 

its contents). 

To password-protect a workbook:

1. Click the File tab to go to the Backstage.

2. In the Info section of the Backstage, click 

the Protect Workbook icon and choose 

Encrypt with Password (Figure 8.64).

The Encrypt Document dialog box appears 

(Figure 8.65).

3. Type a password and click OK.

The Confirm Password dialog box opens.

4. Reenter the password and click OK.

Note that letter case counts; that is, Newt7, 

newt7, and NEWT7 are all different.

✔ Tip

■ You can also set a password while saving 

a workbook with the Save As command. 

Open the Tools menu at the bottom of the 

Save As dialog box and choose General 

Options. In the General Options dialog box 

(Figure 8.66), do one of the following:

▲ Open protection. To prevent 

unauthorized users from opening the 

workbook, enter a password in the 

Password to open box. Excel encrypts 

the workbook when saving it.

▲ Modify protection. To prevent 

unauthorized users from modifying 

the workbook but still let them view 

it, enter a password in the Password to 

modify box. No encryption is added. 

Users who cannot supply the pass-

word will only be allowed to view the 

workbook.

Figure 8.66 Enter a password in the appropriate text 
box and click OK.

Figure 8.65 Type a password in the Encrypt Document 
dialog box and click OK.

Figure 8.64 You can encrypt and password-protect 
the current workbook in the Backstage.
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To open a protected workbook:

1. Open the workbook file.

2. Depending on the type(s) of password 

protection associated with the file (see 

previous Tip), one of the following occurs:

▲ Open protection. A Password dialog 

box appears (Figure 8.67). Enter the 

password and click OK. If the password 

is incorrect or Cancel is clicked, the 

workbook does not open. 

▲ Modify protection. A Password dialog 

box appears (Figure 8.68). Enter the 

password for permission to modify 

the workbook or click Read Only for 

permission to only view the workbook.

To remove or change a password:

1. Open the workbook by supplying the 

password. The following occurs:

▲ Open protection. A Password dialog 

box appears (Figure 8.67). Enter the 

password and click OK. If the password 

is incorrect or Cancel is clicked, the 

workbook does not open. 

▲ Modify protection. A Password 

dialog box appears (Figure 8.68). Enter 

the password for permission to modify 

the workbook.

2. Click the File tab to go to the Backstage, 

and then click Save As.

3. Open the Tools drop-down menu at the 

bottom of the Save As dialog box and 

choose General Options. 

4. In the General Options dialog box (see 

Figure 8.66), do any of the following:

▲ To eliminate a password, delete it from 

the appropriate Password text box.

▲ To change a password, delete the old 

password, type a new one, and then 

confirm the change.

continues on next page

Figure 8.67 This dialog box appears when a password 
to open has been set for a workbook.

Figure 8.68 This dialog box appears when a 
password to modify has been set for a workbook.
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5. Click OK to close the General Options 

dialog box. 

6. Optional: In the Save As dialog box, you 

can change the file’s name and/or its  

location on disk. 

7. Click Save. 

Any edits made to passwords, as well as 

password deletions, are recorded in the 

saved file. The edits and deletions will be 

in effect the next time you open the file.

✔ Tips

■ Save an unprotected, archival copy of 

the workbook to CD or another type of 

removable media—just in case you forget 

the password(s).

■ Use the Password to modify option when 

one or more users need to view a work-

book but not change it. Restrict access to 

that password to those few users (or only 

yourself ) who have permission to change 

the data.

■ If you assign both types of password to 

a workbook, be sure to use two different

passwords.
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