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9
Although you’re free to accept the default 

formatting for any worksheet by using the 

preset column widths, row heights, font, and 

font size, you’re unlikely to do so very often. 

Simply put, properly formatted worksheets 

are easier to read and understand than those 

that use the default settings. 

And if you apply Excel’s attractive formatting 

features (such as shading and border styles 

for cells, and fonts, styles, colors, and alignment 

for data), you can transform a run-of-the-mill 

worksheet into something worthy of being 

published in a corporate report.

✔ Tip

■ For information on formatting tables, see 

Chapter 11.

Formatting 
Worksheets  
and Data
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Setting Column Width and  
Row Height
Unless you’ve set a specific width for a column 

or height for a row, each row and column 

automatically adjusts to fit the data it contains, 

as follows:

◆ Row height adjusts to the largest font size 

in any cell within the row.

◆ Column width adjusts to the longest 

number in any cell within the column. 

A lengthy text string in a cell (Figure 9.1), 

on the other hand, does not result in a 

column-width adjustment. If adjacent 

cells are empty, the extra text spills into 

them. If adjacent cells contain data, only 

the text that fits within the current cell 

width is displayed.

To set a column width:

1. To select the column(s), do one or a combi-

nation of the following:

▲ Single column. Click its letter or 

select a single cell within the column. 

▲ Multiple contiguous columns. Drag-

select the column letters. 

▲ Multiple noncontiguous columns. 

c-click each column letter.

2. On the Home tab, click the Format icon in 

the Cells group. Do one of the following:

▲ To set a single width for all selected 

columns, choose Column Width from 

the drop-down menu (Figure 9.2). In 

the Column Width dialog box (Figure 

9.3), enter a number (representing the 

approximate number of characters), 

and click OK.

▲ Choose AutoFit Column Width. Excel 

will continually adjust the column 

width to the longest number or text 

string that appears anywhere in each 

of the selected columns.

Figure 9.1 Cells A1 and A2 contain the same text 
string. Because cells B1 and C1 are empty, A1’s 
text spills into them. But because B2 contains 
data, the text string in cell A2 is truncated.

Figure 9.3 Enter a new column width (in 
characters) and click OK.

Figure 9.2 Choose a column width 
or row height command.
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To set a row height:

1. To select the row(s), do one or a combina-

tion of the following:

▲ Single row. Click its number or select 

a single cell within the row. 

▲ Multiple contiguous rows. Drag-

select the row numbers. 

▲ Multiple noncontiguous rows. 

c-click each row number.

2. On the Home tab, click the Format icon in 

the Cells group. Do one of the following:

▲ To set a single height for all selected 

rows, choose Row Height from the 

drop-down menu (see Figure 9.2). In 

the Row Height dialog box (Figure 9.4), 

enter a height in points (72 points per 

inch) and click OK.

▲ Choose AutoFit Row Height. Excel will 

continually adjust the row height to 

accommodate the largest font or text 

wrap in each of the selected rows.

✔ Tips

■ You can manually adjust column widths 

and row heights:

▲ Column width. Click the right border 

of the column’s letter and drag to the 

left or right (Figure 9.5). 

▲ Row height. Click the bottom border 

of the row’s number and drag up or 

down.

■ You can simultaneously set a width or 

height for multiple columns or rows. 

Select the columns or rows, and then 

manually adjust the width or height of 

any one of them.

■ To instantly make a column wide enough 

to accommodate the longest number or 

text string in the column, double-click the 

column letter’s right border. To adjust a 

row height in the same manner, double-

click the row number’s bottom border. 

Figure 9.4 Enter a new row height (in 
points) and click OK.

Figure 9.5 Click and drag between column 
letters to resize the column on the left (in 
this case, column D).
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About Data and Cell 
Formatting
If you start a new worksheet by simply enter-

ing data, it will all have the same formatting. 

Every text and number entry will use the same 

font, size, style, and color. Numbers will be 

displayed using the General format (as typed, 

unless the column isn’t wide enough to show 

the entire number). Cells will have no back-

ground color and no borders.

However, Excel offers many data- and cell-

formatting options. To make any worksheet 

more attractive and easier to interpret, you 

can do the following:

◆ Apply different fonts, styles, sizes, and/or 

colors to data within selected cells.

◆ Set paragraph alignment for individual 

cells (left-, center-, or right-aligned).

◆ Wrap text within cells or shrink it to fit, 

rather than let it the spill into adjacent cells.

◆ Apply a variety of Number formats to cells 

that contain numeric data, such as setting 

the number of decimal places and format-

ting as currency or percentages.

◆ Use conditional formatting to make certain 

numbers stand out, such as values below 

the average or values that correspond to a 

rule of your own creation.

◆ Fill cells with color.

◆ Add borders (lines) around cell edges.

✔ Tips

■ If you don’t care for the default font used 

to format worksheets, you can change it. 

Click the File tab to go to the Backstage, 

and then click Options. In the General 

section of the Excel Options dialog box 

(Figure 9.6), choose a new font and/or 

size, and click OK.

■ Displaying the gridlines on any worksheet 

is traditional—but optional. To hide the 

gridlines, click the View tab and remove 

the check mark from Gridlines in the 

Show group.

Figure 9.6 You can change the default font and/or 
font size for all new worksheets.
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Character and Paragraph 
Formatting
By choosing commands from the Home tab 

or the Mini toolbar, you can specify a font for 

selected text within a cell or the entire cell, as 

well as change the paragraph alignment.

To set character or paragraph 
formatting:

1. Do one of the following:

▲ To format all text within a cell, select 

the cell.

▲ To format only certain text within a cell, 

select the text you want to format.

2. To apply character formatting, do any of 

the following:

▲ On the Home tab, choose character-

formatting commands from the Font 

group (Figure 9.7).

▲ Right-click the cell or selected text, 

and choose formatting commands 

from the Mini toolbar (Figure 9.8).

▲ Click the Cell Styles icon in the Styles 

group and choose a style from the gal-

lery (Figure 9.9). Note that cell styles 

can only be applied to an entire cell— 

not to selected text within a cell.

3. To apply paragraph formatting, choose 

commands from the Alignment group on 

the Home tab (Figure 9.10).

✔ Tip

■ Character and paragraph formatting can 

also be applied to multiple selected cells 

simultaneously. Use any of the selection 

techniques described on pages 160–161 

prior to choosing formatting commands.

Figure 9.7 Character-formatting commands 
can be selected from the Font group.

Figure 9.8 The Mini toolbar displays different 
formatting commands when text within a cell (top) or 
the cell itself (bottom) is selected.

Character-formatting 
commands only

Figure 9.9 Choose a style from the Cell Styles gallery 
to format headings, titles, totals, and good/bad data.

Figure 9.10 Choose paragraph-formatting commands 
from the Alignment group.

  



ptg

Chapter 9

192

F
i
t

t
i
n

g
 T

e
x

t
 W

i
t

h
i
n

 a
 C

e
l
l

Fitting Text Within a Cell
Occasionally, a cell can contain more text 

than will fit. To fully display the text, you can 

allow the additional characters to overflow 

into adjacent cells, widen the column in which 

the cell is located, or use one of the methods 

described below.

To enable text wrap:

1. Select the cell or cells in which you want 

text to wrap.

2. On the Home tab, click the Wrap Text icon 

in the Alignment group (see Figure 9.10).

Text within the selected cells wraps. The 

row height increases as needed in order to 

accommodate present and future text in 

the row (Figure 9.11).

To shrink text to fit a cell:

1. Select the cell or cells containing text you 

want to shrink to fit the cell width.

2. On the Home tab, click the Format icon in 

the Cells group and choose Format Cells.

The Format Cells dialog box appears.

3. On the Alignment tab (Figure 9.12), click 

Shrink to fit and then OK.

Text in the cells is reduced as necessary in 

order to fit the cell widths.

✔ Tips

■ To eliminate text wrap from selected cells, 

click the Wrap Text icon again.

■ If you’ve enabled text wrap, you may also 

want to set a vertical alignment for the 

entire row or selected cells within the row 

(Figure 9.13).

■ If you set a specific height for a row, its 

height will no longer increase to accom-

modate text wrap.

■ Wrap Text and Shrink to Fit are mutually 

exclusive. To enable Shrink to Fit in the 

Format Cells dialog box, you must first 

remove the check mark from Wrap Text 

(if present).

■ You can also open the Format Cells dialog 

box by clicking the Format Cells dialog 

box launcher in the Font, Alignment, or 

Number group (Figure 9.13).

Figure 9.11 Long text, such as the string in cell A1, can 
be wrapped within its cell.

Format Cells dialog box launcher

Top, Middle, and Bottom Align icons

Figure 9.13 Bottom Align was set for the column heads 
in cells B1 and C1 in Figure 9.11 (above).

Figure 9.12 Click Shrink to fit and then click OK.
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Number Formatting
Like any modern spreadsheet application, 

Excel 2010 offers many formats that you can 

apply to numeric, date, and time data. You 

can format numbers as currency, percentages, 

fractions, or scientific notation, for example. 

You can optionally display numbers with 

commas and a fixed number of decimal places. 

Note that the display options set for a given 

cell do not affect the way its number is stored 

or used in calculations. For instance, if you 

apply a currency format to a cell containing 

28.1225, $28.12 will display. The remaining 

.0025 isn’t gone; it simply isn’t shown.

To apply a Number format:

1. Select the cell or cells to which you want 

to apply a Number format.

2. Do one of the following:

▲ On the Home tab, choose formatting 

options from the Number group 

(Figure 9.14).

▲ Right-click any selected cell and choose 

format options from the Mini toolbar 

(see Figure 9.8).

▲ Click the Format Cells dialog box 

launcher (see Figure 9.13). Choose 

formatting options from those on the 

Number tab (Figure 9.15). Click OK to 

apply the options to the selected cells.

✔ Tip

■ Be sure to thoroughly explore the Number 

tab of the Format Cells dialog box. It also 

includes date and time formatting options. 

And if you choose the Special category, 

you’ll find formats for ZIP codes, phone 

numbers, and Social Security numbers.

Figure 9.14 Choose common 
number-formatting options 
from the Number group.

Display commas

Increase/decrease 
decimal places

Number format 
drop-down menu

Format Cells dialog 
box launcher

Currency symbol drop-down menu

Figure 9.15 For more complex formatting, as well as 
date and time formats, use the Format Cells dialog box.

Category list Options
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Conditional Formatting
By specifying conditional formatting (format-

ting that’s applied only when specified criteria 

are met), you can make important data stand 

out from other elements in a data set. You can 

do any of the following:

◆ Overlay every member of the data set 

with a data bar, color, or icon that shows 

its position in the distribution.

◆ Apply a color highlight to a specific 

number of items that are highest, lowest, 

above average, or below average.

◆ Apply a color highlight to items identified 

by a rule, such as bowling averages greater 

than 200.

Unlike manually applied formatting, condi-

tional formatting updates itself as required. 

That is, if the data that has been conditionally 

formatted changes, the items formatted in this 

manner (highlighted in green, for instance) 

will automatically change, too.

To apply data bars, color scales, or 
icon sets to data:

1. Select the cell range to which you want to 

apply conditional formatting.

2. On the Home tab, click the Conditional 

Formatting icon in the Styles group.

A drop-down menu appears (Figure 9.16).

3. Choose an option from the Data Bars, 

Color Scales, or Icon Sets submenu 

(Figure 9.17).

A live preview is provided for each condi-

tional formatting option.

Figure 9.16 Choose conditional formatting from this 
drop-down menu in the Styles group of the Home tab. 

Figure 9.17 You can show the relative size of every 
item in a data distribution by formatting with data 
bars, a color scale, or an icon set.

Data Bars Color Scales Icon Sets
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To apply a Top/Bottom Rule to data:

1. Select the cell range to which you want to 

apply a Top/Bottom Rule.

2. On the Home tab, click the Conditional 

Formatting icon in the Styles group.

3. From the drop-down menu that appears, 

choose an option from the Top/Bottom 

Rules submenu (Figure 9.18).

4. Set options in the dialog box that appears 

(Figure 9.19). A live preview is shown.

▲ For Average rules, the dialog box 

allows you to select fill and text colors. 

▲ For Top and Bottom rules, you can 

also set the cutoff point (as a number 

or percentage), highlighting only the 

lowest five scores, for example.

5. Click OK to apply the rule to the selected 

cell range.

To apply a Highlight Cells Rule to data:

1. Select the cell range to which you want to 

apply a Highlight Cells Rule.

2. On the Home tab, click the Conditional 

Formatting icon in the Styles group.

3. From the drop-down menu, choose an 

option from the Highlight Cells Rules 

submenu (Figure 9.20).

4. In the dialog box that appears, set options 

and click OK to apply the rule.

✔ Tips

■ You can apply multiple types of conditional 

formatting to the same range. 

■ To remove conditional formatting, select 

the range, open the Conditional Formatting 

drop-down menu, and choose Clear Rules > 

Clear Rules from Selected Cells.

Formatting optionsNumber or percentage

Figure 9.19 Set options for the rule and click OK.

Figure 9.18 Choose an option from the 
Top/Bottom Rules submenu to select the 
highest/lowest items or those above/below 
the average for the data set.

Figure 9.20 Highlight 
Cells Rules submenu.
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Adding Cell Backgrounds 
and Borders
In addition to formatting cell content, you 

can apply formatting to cell borders and 

backgrounds. For example, you can create a 

double-line border beneath a row to visually 

separate data from a totals row. Or you could 

make critical cells stand out by applying a 

colored fill to them.

To fill cells with color:

1. Select the cells to which you want to apply 

a background color.

2. On the Home tab, open the Format Cells 

dialog box by doing one of the following:

▲ Click the Format icon in the Cells 

group and choose Format Cells from 

the drop-down menu.

▲ Click the Format Cells dialog box 

launcher in the Font, Alignment, or 

Number group (see Figure 9.13).

▲ Right-click one of the selected cells and 

choose Format Cells from the context 

menu that appears.

3. In the Format Cells dialog box, click the Fill 

tab (Figure 9.21).

4. Do one of the following:

▲ Fill cells with a solid color. Click a 

color icon in the Background Color 

section. (To choose a color that isn’t 

displayed, click More Colors.)

▲ Fill cells with a pattern. Choose a 

pattern color and style from the drop-

down menus. 

▲ Fill cells with a gradient. Click the 

Fill Effects button. Set options in the 

dialog box that appears (Figure 9.22) 

and click OK. 

5. Click OK to close the Format Cells 

dialog box. 

Figure 9.21 Select fill options on the Fill tab of the 
Format Cells dialog box.

Color fills Pattern fill settings

Preview of color, pattern, or gradient fill

Figure 9.22 You can apply a custom gradient to cells. 
Doing so often results in a 3D-like effect.

Preview
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To add cell borders:

1. Select the cells to which you want to add 

one or more border lines.

2. On the Home tab, open the Format Cells 

dialog box by doing one of the following:

▲ Click the Format icon in the Cells 

group and choose Format Cells from 

the drop-down menu.

▲ Click the Format Cells dialog box 

launcher in the Font, Alignment, or 

Number group (see Figure 9.13).

▲ Right-click one of the selected cells and 

choose Format Cells from the context 

menu that appears.

3. In the Format Cells dialog box, click the 

Border tab (Figure 9.23).

4. Do any of the following:

▲ Add border lines. Select a line style 

and color from the left side of the dialog 

box. To use one of the presets (such as 

Outline), click its icon. To add a single 

border line of the selected style and 

color, click its border icon or the spot 

in the sample where you want to add 

the line. 

▲ Remove border lines. To simultane-

ously remove all border lines from the 

selected cells, click the None preset. To 

remove a single border, click its border 

icon or the spot in the sample from 

which you want to remove the line.

▲ Change border line properties. To 

change the style or color of borders, 

select a new style and/or color, and 

click the preset or border icon that you 

want to reformat.

5. Click OK to close the dialog box.

✔ Tip

■ Border styles can also chosen from the 

drop-down menu in the Font group.

Figure 9.23 You can add, remove, or modify borders 
for the currently selected cells.

PresetsLine styles

Line color Border icons

Custom Conditional Formatting

While you can quickly apply conditional 

formatting to a range by merely choosing 

an option from one of the Conditional 

Formatting submenus (see Figures 9.16, 

9.18, and 9.20), you can customize the set-

tings for any conditional formatting rule 

to show only particular values in a speci-

fied manner. 

Choose More Rules from the bottom of 

the appropriate Conditional Formatting 

submenu. Depending on the conditional 

formatting type, you can specify a minimum 

and/or maximum plotted value, indicate 

how negative values will be displayed, or 

change the number of plotted values for a 

top/bottom rule, for example.
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Removing, Replacing, and  
Reusing Formats
Whether you’ve applied character, paragraph, 

number, or conditional formatting, the applied 

formatting can be removed or replaced. And 

to simplify the process of applying existing 

formatting to additional cells or ranges, you 

can also reuse formatting.

To remove formatting:

1. Select the cell range from which you want 

to remove formatting, and switch to the 

Home tab.

2. Do any of the following:

▲ To remove all character, paragraph, 

and number formatting, click the Clear 

icon in the Editing group and choose 

Clear Formats from the drop-down 

menu (Figure 9.24). 

▲ To selectively remove character style 

formatting (bold, italic, underline, or 

double underline) from selected cells 

or selected characters within a cell, 

reapply the style formatting option.

▲ To remove conditional formatting 

from the selected cells, open the 

Conditional Formatting drop-down 

menu and choose Clear Rules > Clear 

Rules from Selected Cells. 

▲ To remove all conditional formatting 

from the current worksheet, click 

the Conditional Formatting icon and 

choose Clear Rules > Clear Rules from 

Entire Sheet.

✔ Tips

■ Applying Clear Formats also causes cell 

data to revert to the default font and size.

■ The Clear Formats command can also be 

used to remove conditional formatting.

Figure 9.24 Choose Clear Formats 
to remove all formatting from the 
selected cells.

Clear icon
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Format Painter icon

Figure 9.25 Use the Format Painter tool to copy cell 
formatting to another cell or range.

To replace formatting:

1. Select the cell range for which you want to 

replace or modify the current formatting. 

Switch to the Home tab.

2. Do any of the following:

▲ To alter paragraph formatting, choose 

options from the Alignment group (see 

Figure 9.10).

▲ To set a new font or size, select options 

from the Font group (see Figure 9.7) or 

the Mini toolbar (see Figure 9.8).

▲ To replace or modify Number format-

ting, select options from the Number 

group (see Figure 9.14) or the Number 

tab in the Format Cells dialog box (see 

Figure 9.15).

To reuse existing formatting:

1. Select a cell that contains the formatting 

you want to duplicate.

2. On the Home tab, click the Format Painter 

icon in the Clipboard group (Figure 9.25).

3. Do either of the following:

▲ Click the cell to which you want to 

apply the formatting.

▲ Drag-select the cell range to which 

you want to apply the formatting.

✔ Tip

■ You can also reapply existing formatting 

using copy-and-paste. First, copy (cC) 

the cell whose formatting you want to 

reuse. Next, select the target cells, click 

the Paste icon in the Clipboard group of 

the Home tab and click the Formatting 

icon (Figure 9.26). You can also specify 

copied properties that you want to paste 

by choosing Paste Special from the Paste 

icon’s drop-down menu.

Figure 9.26 To perform a 
normal paste, click the Paste 
icon. To paste anything other 
than copied data (such as 
formatting), click an icon in 
the Paste drop-down menu.
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Figure 9.28 Choose a color for the current 
tab. Choose No Color to remove a previously 
applied color.

Selected tab
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Worksheet Formatting
In addition to specifying a new default font 

and size, as well as turning off the display of 

gridlines, you may occasionally want to try 

some of these sheet-formatting options:

◆ Background. You can use any image 

from your hard disk as a background for 

the current sheet (Figure 9.27). On the 

Page Layout tab, click the Background 

icon in the Page Setup group, select an 

image from the Sheet Background dialog 

box, and click Open.

◆ Themes. If you don’t feel like manually 

selecting fonts, colors, and effects, you 

can choose a predesigned theme. Select 

the Page Layout tab and view the Themes 

gallery in the Themes group. Each theme 

contains a complementary set of fonts, 

colors, and effects. When you insert a new 

chart or SmartArt graphic, for example, 

theme formatting is automatically used. 

Similarly, when you select a color for text 

or an object, the color set will display only 

variations of the theme colors.

◆ Tab Color. You may find it helpful to 

color-code the sheet tabs in a workbook 

to make them easier to identify. To do so, 

right-click a sheet tab and choose a color 

from the Tab Color pop-out (Figure 9.28).

Figure 9.27 As long as you apply contrasting font 
colors, a photo or graphic can serve as an interesting 
sheet background. 

Remove background
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