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10
After familiarizing yourself with Excel’s list 

management features (using it to record 

mailing lists and membership rosters, for 

example), you’ll want to explore its extensive 

calculation capabilities. By combining the 

contents of specific cells with each other or 

constants, you can create formulas. For 

example, you can add two cells’ contents, 

divide the contents of one cell by that of 

another, or multiply a cell’s contents by a 

constant, such as a sales tax percentage or a 

commission rate. 

You can also use Excel functions in your for-

mulas. For instance, rather than laboriously 

adding the contents of several dozen cells, you 

can use the SUM function to generate a total 

for the range. In support of your calculation 

needs, Excel provides more than 300 built-in 

functions.

In this chapter, you’ll learn the basics of com-

bining cell references, constants, and functions 

into useful formulas. Techniques for trouble-

shooting formulas are also presented.

Formulas 
and Functions
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About Cell References
Although a formula can be composed solely 

of constants, such as =12+5, you’ll seldom use 

Excel to perform such calculations. Almost 

all formulas include cell references, such as 

=A2+5. This formula is interpreted by Excel as: 

“Take the current contents of cell A2 and add 

5 to it.” 

A1 reference style
By default, Excel worksheets use A1 reference 

style in which columns are lettered and rows 

are numbered. Each cell address is named for 

the intersection of the column and row in 

which the cell is located. For example, G7 is 

the cell found at the intersection of column G 

and row 7. A range is represented as a pair of 

addresses separated by a colon (:). For example, 

B3:B6 means all cells between cells B3 and B6 

inclusive—that is, B3, B4, B5, and B6. Refer to 

Table 10.1 for some additional examples.

3-D reference style
Excel also provides a 3-D reference style that 

allows you to include cells and ranges from 

other sheets in your formulas, as well as per-

form calculations across workbook sheets: 

◆ To include a cell or range from another 

sheet in a formula, you precede the cell 

or range address with the sheet’s name 

followed by an exclamation point:

=Sheet2!a7-8

In this example, 8 is subtracted from the 

contents of cell A7 on Sheet2.

◆ To consolidate data across multiple sheets, 

precede the cell or range address with the 

sheet range:

=SUM(Sales1:Sales12!G50)

Table 10.1

A1 Reference Style Examples
E x a m p l e E x p l a n a t i o n

R5 Cell in column R, row 5

B3:E3 Cells B, C, D, and E in row 3 

3:3 Row 3

F:F Column F 

5:8 Rows 5, 6, 7, and 8

A:C Columns A, B, and C

A1:B3 All cells between cells A1 and B3 inclusive  
(A1, B1, A2, B2, A3, and B3)
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In this example, monthly sales are 

recorded in the first 12 sheets, each of 

which is named Sales, followed by the 

month number. Consolidating data this 

way assumes you have laid out the data in 

the sheets (Sales1–Sales12) in identical 

fashion; that is, the cell (G50, in this case) 

contains the appropriate number in each 

sheet, such as total monthly sales or Janice’s 

monthly commissions. 

Structured reference style
Excel 2007 introduced structured reference 

style, a simplified means of addressing table 

data. When you create a formula in a table (a 

calculated column, for example), table-based 

structured references are automatically used 

rather than specific cell addresses (Figure 10.1). 

✔ Tips

■ When referring to a table cell in a formula, 

you can use structured or A1 reference 

style. If you point to the cell to add it to the 

formula, structured reference style is used.

■ If you prefer, you can use R1C1 reference 

style, in which both rows and columns are 

numbered (Figure 10.2). R1C1 reference 

style is generally used in Excel scripts 

(called macros). To enable R1C1, click the 

File tab to display the Backstage and then 

click Options. In the Excel Options dialog 

box, select the Formulas category, click 

the R1C1 reference style check box in the 

Working with formulas section, and then 

click OK.

■ In 3-D reference style, only certain func-

tions can be used to consolidate data 

across sheets. For a list of these functions, 

see Table 10.2. Supported variants of 

these functions that can be applied to 

text and logical values include AVERAGEA, 

COUNTA, MAXA, MINA, STDEVA, STDEVPA, VARA, 

and VARPA.

Table 10.2

3-D Reference Style Functions
F u n c t i o n D e s c r i p t i o n

AVERAGE Calculates the average (arithmetic mean) 

COUNT Counts the cells that contain numbers 

MAX Returns the largest value in referenced cells 

MIN Returns the smallest value in referenced cells 

PRODUCT Multiplies numbers in referenced cells 

STDEV Calculates the standard deviation, based on 
a sample

STDEVP Calculates the population standard deviation 

SUM Adds numbers in referenced cells 

VAR Calculates the variance, based on a sample 

VARP Calculates the population variance

Figure 10.1 In Table 1 (top), Total (column E) is a 
calculated column. When the formula is expressed in 
structured reference style (bottom), it is identical in 
every cell in the column.

Figure 10.2 In R1C1 reference style, both rows and 
columns are numbered.
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Formula Essentials
This section presents the background infor-

mation you’ll need to create formulas.

Anatomy of a formula
A basic formula (Figure 10.3) consists of a 

combination of cell references, constants, and 

operators. (A constant is any data entered in a 

cell, such as text or a number, date, or time.) To 

distinguish a formula from data, every formula 

begins with an equal (=) symbol.

Operators
Operators are used to specify the type of 

calculation to perform, such as addition or 

multiplication. Operators can be divided into 

four categories: arithmetic, comparison, text 

concatenation, and reference.

◆ Arithmetic operators. Used to perform 

mathematical calculations, producing a 

numerical result. 

◆ Comparison operators. Used to perform 

logical comparisons between two values, 

resulting in either True or False. 

◆ Text concatenation operator. Used to 

combine two text values, producing a 

single text string.

◆ Reference operators. Used to specify cell 

ranges.

See Tables 10.3–10.6 for lists of supported 

operators.

Table 10.3

Arithmetic Operators
O p e r a t o r D e s c r i p t i o n E x a m p l e

+ Addition A3+5
– Subtraction 18-B7 
– Negation -17
* Multiplication A6*B6
/ Division G4/3
% Percent 35%
^ Exponentiation (raise to a power) A4^2

Table 10.4

Comparison Operators
O p e r a t o r D e s c r i p t i o n E x a m p l e

= Equal A3=B5
> Greater than D2>12 
< Less than E3<E4
>= Greater than or equal to A6>=15
<= Less than or equal to G4<=3
<> Not equal to B7<>5

Table 10.5

Text Concatenation Operator
O p e r a t o r D e s c r i p t i o n E x a m p l e

& Concatenation "Phone: "&B5

Table 10.6

Reference Operators
O p e r a t o r D e s c r i p t i o n E x a m p l e

: Range A3:A8 (all cells from A3 to A8)
, Union D2,F2:F5 (cells D2 and F2:F5)

[space] Intersection C4:D7 D6:D8 (cells D6 and D7)

=A3+18
Cell reference

ConstantOperator

Figure 10.3 In this simple formula, 18 is added to the 
data in cell A3. As is the case with all formulas, the 
result is displayed in the cell containing the formula.
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Precedence
When calculating the result of a formula, 

Excel evaluates the elements from left to 

right. However, this holds true only when all 

operators are of the same importance (called 

precedence). Every operator has a precedence, 

as shown in Table 10.7. The higher in the 

table an operator appears, the higher its 

precedence. Thus, when a formula contains 

operators of differing precedence, the calcu-

lations are performed from highest to lowest 

precedence. Here are some examples:

4+2+3  [=9] 

Explanation: All operators have the same 

precedence, so the formula is evaluated from 

left to right.

4*2+3  [=11]

Explanation: Multiplication has a higher 

precedence than addition. But because the 

multiplication occurs first in the formula, the 

left-to-right order is still followed (8+3).

4+2*3  [=10]

Explanation: Multiplication has a higher pre-

cedence, so 2*3 is evaluated first (4+6). 

Note that you can change the order of evalu-

ation by enclosing terms in parentheses. 

Such items are always evaluated first. When 

multiple sets of parentheses are used, items 

in the innermost ones are evaluated first.

4*(2+3) [=20]

Explanation: Because parentheses surround 

the last two terms, they are evaluated first 

(resulting in 5). Without the parentheses, the 

formula would have been evaluated in left-to-

right order: 4*2 (or 8), plus 3, for a result of 11.

Table 10.7

Operator Precedence
O p e r a t o r D e s c r i p t i o n

: Colon (range)

, Comma (union)

[space] Space (intersection)
– Negation
% Percent
^ Exponentiation

*, / Multiplication and division

+, – Addition and subtraction
& Concatenation

=, <>, <=, >= Comparison operators
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Relative, absolute, and mixed
Cell references in formulas can be relative, 

absolute, or mixed. When you enter a refer-

ence by typing an address (such as entering 

=(B2+C2+D2)/3 in cell E2), the references to 

cells B2, C2, and D2 are relative to the loca-

tion of the formula cell (E2). If the formula 

is moved or copied to another cell, Excel 

adjusts the cell references to point to the cor-

rect cells. For example, copying the formula 

to cells E3:E7 results in the correct formula in 

each new cell (Figure 10.4).

You use an absolute reference (preceding both 

the column and row with dollar signs) for a 

cell address that must not change when 

copied or moved. For example, in a business 

mileage worksheet (Figure 10.5), you could 

create a formula to calculate Mileage Amount: 

the trip’s total mileage multiplied by a fixed 

mileage rate (found in cell I2). The initial 

formula in row 2 would be =F2*$I$2 and then 

repeated in every cell in column G (for 

example, =F3*$I$2). Unlike relative references, 

absolute references never change, no matter 

where on the worksheet the formula is copied 

or moved.

Finally, Excel also supports mixed references

in which the column or the row is absolute 

and the other is relative, such as $A1 (column 

A is absolute, row 1 is relative) and A$1 (col-

umn A is relative, row 1 is absolute).

✔ Tip

■ When a formula is copied or moved 

(Figure 10.6), the cell references change 

as shown in Table 10.8:

▲ Relative references change to match 

the formula’s new location, relative to 

the original location. This also applies 

to the relative part of a mixed reference.

▲ Absolute references do not change. 

The absolute portion of a mixed refer-

ence also remains unchanged.

Table 10.8

Result of Copying or Moving a Formula
F o r m u l a  ( C 1 ) C o p i e d /M o v e d  ( D 3 ) R e f e r e n c e  T y p e

=A1 =B3 Relative

=$A$1 =$A$1 Absolute

=$A1 =$A3 Mixed (absolute column)

=A$1 =B$1 Mixed (absolute row)

Formula copied to E3

Figure 10.4 When the formula =(B2+C2+D2)/3 in E2 
is copied to cells E3:E7, the relative cell references 
in the formula automatically adjust to refer to the 
correct cells.

Figure 10.5 The formula in column G uses an absolute 
reference to the fixed mileage rate in cell I2.

Figure 10.6 If a formula in C1 is copied or moved to 
cell D3, it changes as described in Table 10.8.
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Functions
Functions are formula helpers—built-in com-

putational routines that you can include in 

formulas to simplify the creation of complex 

and special-purpose calculations. For instance, 

rather than laboriously totaling a string of 

cells with the formula =A1+A2+A3+A4+A5, you 

can use the SUM function to add the entire 

range: =SUM(A1:A5).

All but a few functions require arguments, 

the data on which the function operates. 

Arguments are enclosed in parentheses and— 

if there are multiple arguments—separated 

by commas. The argument to the SUM function 

above is the range A1:A5. In addition to oper-

ating on a single range, SUM can be used to 

total individual cells and constants, as seen 

in this formula:

=SUM(A1:A5,B7,23)

In this example, the total of cells A1, A2, A3, 

A4, A5, B7, and 23 is calculated.

When the text insertion mark is at the desired 

spot in a formula you’re creating, you can insert 

a function in these ways:

◆ Functions for which you know the spell-

ing and syntax can be typed directly into 

the formula.

◆ On the Formulas tab, you can choose a 

function by clicking an icon in the Function 

Library group (Figure 10.7).

◆ For guidance in selecting a function, click 

Insert Function in the Function Library 

group. In the Insert Function dialog box 

(Figure 10.8), select a function and then 

click OK.

In the latter two function-insertion methods, 

the Function Arguments dialog box appears 

(Figure 10.9). Using the guidance provided, 

enter the argument(s) and click OK to insert 

the function into your formula. 

✔ Tip

■ You can also open the Insert Function 

dialog box by clicking the ƒx icon in the 

formula bar or by pressing s3.

Function categoriesSearch for a function

Description of selected function

Figure 10.8 Select a function, and then click OK.

Figure 10.7 The Function Library group organizes 
Excel functions by category.

Figure 10.9 You can enter arguments by typing, clicking 
a cell, or drag-selecting a range.
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Creating Formulas
Formulas can be created from any combina-

tion of cell contents, constants, and functions. 

Many common formulas, such as sums or 

averages of a column or row, can quickly be 

created using the AutoSum tool.

To create a formula without functions:

1. Select the cell that will contain the formula 

and type an equal sign (=).

2. Construct the formula by typing constants, 

cell references, and operators (Figure 10.10). 

Press e or click the ✔ in the formula 

bar to complete the formula.

The formula is replaced in the cell by the 

calculated result (Figure 10.11).

To create a formula with functions:

1. Select the cell that will contain the formula 

and type an equal sign (=).

2. Insert constants and cell references as 

needed. To insert a function at the text 

insertion mark, do one of the following:

▲ Type the function name, a left paren-

thesis, the argument(s), and a right 

parenthesis.

▲ Choose a function from the Function 

Library group (see Figure 10.7). In the 

Function Arguments dialog box (see 

Figure 10.9), enter the argument(s) and 

click OK.

▲ Click the Insert Function icon in the 

Function Library group or on the 

formula bar. In the Insert Function 

dialog box (see Figure 10.8), select a 

function and click OK. In the Function 

Arguments dialog box (see Figure 10.9), 

enter the argument(s) and click OK.

3. Press e or click the ✔ in the formula 

bar to complete the formula.

The formula is replaced in the cell by the 

calculated result.

Figure 10.11 When you complete a formula, the result 
is displayed in the cell. Note that the formula is shown 
in the formula bar.

Formula Result

Figure 10.10 The formula in E2 totals Michelle’s three 
test scores. As you select cells or type their addresses, 
Excel displays handles around each referenced cell.

Referenced cell
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To create an AutoSum formula:

1. Select the cell at the bottom of a column or 

end of a row that will contain the formula.

The cells that will serve as the argument 

to the AutoSum function must be a con-

tiguous string within a single column or 

row, such as B2:B23 or H7:R7.

2. On the Formulas tab, click the AutoSum 

icon in the Function Library group 

(Figure 10.12). Choose a function from 

the drop-down menu or choose More 

Functions to pick from all Excel functions.

3. Excel highlights the range it thinks you 

want to use as the argument to the func-

tion. Adjust the range, if necessary.

4. Press e to complete the formula.

✔ Tips

■ When you create a formula, a cell reference 

can be typed or added by clicking the cell 

you want to reference. You can type or 

drag-select a range (Figure 10.13) as an 

argument to a function. 

■ Typed cell references can be entered in 

uppercase or lowercase.

■ As explained in Chapter 8, if you’ve named 

cells or ranges, you can substitute the 

names for the addresses and ranges in 

formulas (Figure 10.14).

■ If required, a formula can contain multiple 

functions, as well as functions within func-

tions (called nested functions).

■ If you can type the first few letters of a 

function’s name when creating a formula, 

you can use Formula AutoComplete to 

insert the function (Figure 10.15). 

Double-click the function name in the 

drop-down list.

■ Functions do not ignore empty cells within 

the argument range(s).

Figure 10.12 Choose 
a function from the 
drop-down menu.

Figure 10.13 To specify a range for this SUM function, 
type =SUM( and drag-select the range to be totaled. 
Type the closing parenthesis to complete the formula.

Figure 10.14 Columns D and E have been named 
Start_Mileage and End_Mileage. To calculate total 
mileage for any cell in column F, the names can be 
substituted for the two cell references.

Formula in F2

Figure 10.15 Double-click a function 
name to insert it into the formula.

Formula 
AutoComplete 
drop-down list

Formula cell
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Editing Formulas
You can edit existing formulas to correct 

errors and to change cell or range references. 

Many of the techniques described below are 

also applicable to editing data.

To edit a formula:

1. Select the cell that contains the formula 

you want to edit.

2. You can edit in the cell or the formula bar, 

whichever is most convenient. Do one of 

the following:

▲ Double-click the cell.

▲ Click in the formula bar to set the text 

insertion mark.

3. Do any of the following:

▲ Use normal text-editing techniques to 

add, delete, or change the cell contents.

▲ To clear the cell, drag-select its contents 

and press B, or select the cell 

and press d or D.

▲ To change a cell reference from relative, 

absolute, or mixed to another reference 

type, select the address within the 

formula and repeatedly press 4.

▲ To replace a function, select its name 

in the formula and begin typing the 

new function’s name. Select the 

desired function from the Formula 

AutoComplete list by double-clicking 

its name (see Figure 10.15). You can 

also replace a selected function name 

by choosing a new function from the 

Function Library group (Figure 10.16).

4. Press e to complete the formula.

✔ Tip

■ To make an entry in a cell in multiple 

worksheets, c-select the sheet names 

in the Sheet tab bar, select the cell, and 

then enter the data or formula.

Figure 10.16 Functions can be chosen from the Function 
Library group’s icons. If you regularly use a function, 
you can often choose it from the Recently Used icon’s 
drop-down menu.
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Troubleshooting Tips
Following are some techniques for finding 

and correcting errors in formulas. Start by 

switching to the Formulas tab to make the 

icons in the Formula Auditing group (Figure 

10.17) accessible:

◆ Formulas replaced by data. To find cells 

in which you’ve accidentally replaced a 

formula with data, click Show Formulas. 

Any cell containing a formula will now 

display the formula, rather than the result. 

Click Show Formulas again to restore the 

worksheet to its normal state. 

◆ Circular references. If the formulas in 

two cells rely on each other, Excel cannot 

correctly perform the calculations. This 

is known as a circular reference and is 

denoted on the worksheet by an arrow 

connecting the two cells (Figure 10.18). 

You can also find circular references by 

clicking the Error Checking icon and 

choosing any cell listed in the Circular 

References submenu, as shown in  

Figure 10.19. In a circular reference, only 

one of the two formulas can refer to the 

other cell.

◆ Incorrect result. If a formula displays an 

unexpected result, select the cell and click 

Evaluate Formula. By repeatedly clicking 

the Evaluate button in the Evaluate 

Formula dialog box (Figure 10.20), you 

can step through the elements in the 

formula, displaying the result for each step. 

Evaluating a formula often makes it easy 

to find incorrect cell references and identify 

flaws in a formula’s logic. 

◆ Is it an error? Excel notifies you imme-

diately if it detects a possible formula 

error—often by displaying a tiny triangle 

in the cell’s upper-left corner. Select the 

cell (Figure 10.21) and choose a handling 

option from the drop-down menu.

Figure 10.17 Troubleshooting tools are available in 
the Formula Auditing group of the Formulas tab.

Figure 10.18 This arrow connects two 
cells that reference each other. The 
formula in B11 is =D16; the formula in 
D16 is =B11+8.

Figure 10.19 You can 
go directly to a cir-
cular reference cell.

Figure 10.21 Click the icon and choose an option.

Figure 10.20 Click the Evaluate button to replace the 
underlined formula element with its data. Click Close 
when you’re finished.
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11
Although number-crunching is the purpose 

of the typical worksheet, many worksheets 

are used only to record lists of related data, 

such as addresses, club memberships, or a 

course roster. New users quickly discover 

that a worksheet’s row-and-column grid is 

better for handling lengthy lists than a word 

processing document. Such worksheets are 

essentially simple databases in which each 

row is a record and each column is a field

(Figure 11.1). 

Because so many people use worksheets to 

manage lists, Microsoft added list-related 

features to Excel 2003. In Excel 2007, lists 

were renamed tables. Any area of a worksheet 

can be designated a table, and a worksheet 

can contain as many tables as you need. Here 

are some advantages of formatting data as a 

table rather than using normal Excel format-

ting and tools to manage your list:

◆ Quickly sort the table by the contents of 

any field

◆ Filter the data to show only certain records 

or those that match a criterion

◆ Display a summary statistic for selected 

columns in an optional total row

◆ Simplify the process of performing a 

calculation on row data using calculated 

columns

Working  
with Tables

Figure 11.1 Worksheets often contain lists of related 
data. In this harness-racing worksheet, each row is 
the record for a single horse. Each column is a field, 
such as post position or horse’s name.
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Creating a Table
You can create a table in any blank range or 

convert existing data to a table.

To create a table:

1. Do one of the following:

▲ Select a blank range where you want 

to insert the table.

▲ Select a range with data that you want 

to convert to a table.

2. Do one of the following:

▲ On the Insert tab, click the Table icon 

in the Tables group or press cT.

▲ On the Home tab, click the Format 

as Table icon in the Styles group and 

choose a table format from the gallery 

(Figure 11.2).

The Create Table or Format As Table dialog 

box appears (Figure 11.3).

3. If the proposed table range contains a 

header row, check My table has headers.

4. Click OK to create the table (Figure 11.4).

✔ Tips

■ The menu icons in each cell of the header 

row can obscure the header labels. You 

may want to widen the columns, change 

the alignment, or apply text wrap to any 

lengthy headers.

■ To quickly select a table, click in any table 

cell and then move the cursor over one 

of the table’s top corners. Click when the 

cursor changes to a plus (+) with arrows.

■ To delete a table, select the entire table 

and press d or D.

■ To change a table back to a normal range, 

select any table cell. On the Design tab, 

click the Convert to Range icon in the 

Tools group. Click Yes in the confirmation 

dialog box that appears.

Figure 11.2 One way to create a table is to 
simply format a cell range as a table.

Figure 11.3 Edit the range (if necessary), 
indicate whether the range already contains 
a header row, and then click OK.

Figure 11.4 A table created from a blank range.
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Formatting a Table
A table is just another worksheet range. As 

such, if you aren’t thrilled with the default 

formatting, you can format individual cells, 

rows, columns, or the entire table any way 

you like.

To format a table:

◆ Format the entire table. Select any cell 

in the table. On the Design tab, select a 

new style from the Table Styles gallery.

◆ Format a row, column, or range. Select 

the row, column, or range within the 

table. On the Home tab, select a cell for-

mat from the Cell Styles drop-down menu 

in the Styles group. Alternatively, you can 

apply a fill color, gradient, or pattern to 

selected cells by selecting options on the 

Fill tab of the Format Cells dialog box 

(Figure 11.5).

◆ Format the first or last column. The 

first column often contains record identi-

fiers and the last column is frequently 

used to summarize each record’s data. 

To apply distinctive formatting to these 

columns (boldface and, in some cases, a 

background color), switch to the Design 

tab and click the First Column and/or 

Last Column check boxes in the Table 

Style Options group (Figure 11.6).

◆ Create alternating rows or columns. 

On the Design tab, click Banded Rows or 

Banded Columns in the Table Style Options 

group (Figure 11.6).

✔ Tip

■ The effect of selecting First Column and 

Last Column in the Table Style Options 

group depends on the table’s current 

formatting. For instance, if the entire 

table is formatted with a single color, only 

boldface will be applied to the column.

Figure 11.5 A color fill or gradient can be applied to 
selected table rows, columns, or cells. To display this 
dialog box, switch to the Home tab, click the Format 
icon in the Cells group, and choose Format Cells.

Figure 11.6 Click check boxes in the Table Style 
Options group to hide, show, and format table 
components.
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Creating Calculated 
Columns
Formulas in a table work differently from 

ones found elsewhere in the worksheet. If you 

insert a formula, it’s automatically copied to 

all cells in the same column. And if you later 

add rows to the table, the formula is copied 

to the new cells in the column, too. Any table 

column that contains a formula is referred to 

as a calculated column.

To create a calculated column:

1. If necessary, insert a new column into the 

table in which to place the formula.

To be treated as a calculated column, the 

column must be empty when you create 

the formula. If the column contains any

data, the formula will be applied only to 

the current cell.

2. Select a cell in the empty column, and 

type or paste the formula into the cell.

Many table formulas are automatically 

converted by Excel to equivalent struc-

tured references (Figure 11.7).

3. Complete the formula by pressing e

or clicking ✔ (Enter) in the formula bar 

(Figure 11.7).

The formula is automatically copied to all 

other cells in the column (Figure 11.8).

✔ Tips

■ If you replace the formula with data in any 

cell in a calculated column, Excel marks 

the cell as an exception. You can correct an 

exception by clicking the indicator beside 

the cell (Figure 11.9).

■ As long as a calculated column contains 

no exceptions, you can replace the formula 

with a new one. Like the original formula, 

it will automatically copy itself to every 

cell in the column.

Figure 11.7 Formulas within tables are often 
converted into structured references.

Enter

Figure 11.9 An exception cell in a calculated column 
is denoted by a tiny triangle in the cell’s upper-left 
corner. When you move the cursor over the indicator 
beside the cell, an explanatory message appears.

Figure 11.8 The Win % calculated 
column is based on the formula 
=Wins/Races.

Calculated 
column

  



ptg

Microsoft Excel: Working with Tables

217

A
d

d
i
n

g
 a

 T
o

t
a

l
 R

o
w

Adding a Total Row
A table can optionally have a single total row

at its bottom, enabling you to calculate a 

summary statistic across all records in the 

table. Each column can display a different 

statistic or none at all. For instance, in a 

donations table, you could compute the total 

of all donations, the average of the most recent 

donation (across all donors), or a count of the 

number of donor records.

To add a total row to a table:

1. Select a cell in the table to make the table 

active.

2. On the Design tab, click the Total Row 

check box in the Table Style Options group 

(see Figure 11.6).

The total row appears at the bottom of the 

table (Figure 11.10).

3. Optional: Edit or delete the Total label in 

the leftmost cell of the total row.

4. To display a summary statistic for a 

column, click the total row cell beneath 

the column. Click the icon that appears 

beside the cell and choose a statistic from 

the drop-down menu (Figure 11.11).

5. Repeat Step 4 for each additional column 

that you want to summarize.

6. Format the total row cells as desired.

✔ Tips

■ If the function you need isn’t listed in the 

drop-down menu, choose More Functions.

■ To eliminate the summary statistic for a 

column, choose None from the drop-down 

menu (Figure 11.11).

■ You can disable and enable the total row 

as needed. When you re-enable the total 

row, any statistic previously specified for a 

column reappears.

Figure 11.10 When enabled, a total row appears at the 
bottom of the table.

Total row

Figure 11.11 Each cell in the total row has a drop-down 
menu from which you can choose a statistical function.
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Sorting and Filtering
Excel provides two tools that simplify viewing 

and analyzing table data:

◆ Sorting. Sort an entire table based on the 

contents of one or more fields (columns).

◆ Filtering. Restrict visible records (rows) 

to those that match a criterion. If desired, 

criteria can be chosen from multiple 

columns. For instance, you might filter a 

business table to show June absences of 

employees earning less than $10 per hour.

To sort a table:

1. Do one of the following:

▲ In the header row, click the icon in 

the column by which you want to sort 

(Figure 11.12).

▲ Right-click in any cell of the column by 

which you want to sort and open the 

Sort submenu (Figure 11.13).

▲ Select any cell in the column by which 

you want to sort. On the Home tab, 

click the Sort & Filter icon in the Editing 

group.

2. Choose a sort order (ascending or descend-

ing) from the menu.

The table is sorted as specified.

✔ Tip

■ You can perform a multi-field sort by 

choosing Custom Sort. In the Sort dialog 

box that appears, click the Add Level icon 

to add additional sort fields, such as 

sorting by Payee and then by Amount.

Figure 11.12 Click the icon of the header cell for the 
column by which you want to sort the table …

Figure 11.13 … or right-click any cell in the column by 
which you want to sort and choose an option from 
the Sort submenu.
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To filter a table:

1. Do either of the following:

▲ In the header row, click the icon in the 

column by which you want to filter the 

table (Figure 11.14).

▲ To filter based on a cell’s contents or 

properties, right-click the cell in the 

column by which you want to filter 

the table and open the Filter submenu 

(Figure 11.15).

2. Choose or specify a filter criterion. 

Records that do not match the filter crite-

rion are hidden. If present, statistics in the 

total row are recalculated to reflect only 

the visible records.

✔ Tips

■ To remove all filtering effects from a table 

(restoring the full record set), switch to the 

Home tab, click the Sort & Filter icon in 

the Editing group, and choose Clear from 

the drop-down menu (Figure 11.16).

■ To selectively remove one table filter when 

one or more filters have been applied, 

click the icon in the column header whose 

filtering you want to remove and choose 

Clear Filter From “field name.”

■ If you’ve added records to a table, you 

can reapply the current sort instructions 

and filter criteria to accommodate the 

new records. On the Home tab, click the 

Sort & Filter icon in the Editing group 

and choose Reapply from the drop-down 

menu (Figure 11.16).

Figure 11.14 There are two ways to set a filter criterion. 
First, you can clear check boxes to filter out matching 
data. Second, you can specify a formula-based criterion 
by choosing a command from the pop-out menu.

Figure 11.15 You can also filter the data based on the 
selected cell, but your options are limited.

Figure 11.16 Sort & Filter icon.
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Changing a Table’s Size
Table contents can change over time. In addi-

tion to editing the data, you may want to add 

or delete fields (columns), as well as add or 

delete records (rows).

To change a table’s size:

◆ Insert records (rows) within a table. 

Select a cell in the row beneath where 

you want to insert a new row. (To insert 

multiple rows in the same spot, begin by 

selecting that number of cells in adjacent 

rows.) On the Home tab, click the Insert 

icon in the Cells group and choose Insert 

Table Rows Above (Figure 11.17).

◆ Insert fields (columns) within a table.

Select a cell in the column to the right of 

where you want to insert a new column. 

(To insert multiple columns in one spot, 

begin by selecting that number of cells in 

adjacent columns.) On the Home tab, 

click the Insert icon in the Cells group and 

choose Insert Table Columns to the Left 

(Figure 11.17).

◆ Increase a table’s size by dragging. Move 

the cursor over the lower-right corner of 

the table. When the cursor changes as 

shown in Figure 11.18, drag to the right 

to add columns or drag down to add rows.

◆ Delete records (rows). Select one or 

more cells in the row or rows you want to 

delete. On the Home tab, click the Delete 

icon in the Cells group and choose Delete 

Table Rows (Figure 11.19).

◆ Delete fields (columns). Select one or 

more cells in the column or columns you 

want to delete. On the Home tab, click the 

Delete icon in the Cells group and choose 

Delete Table Columns (Figure 11.19).

Figure 11.17 To insert or delete table rows or 
columns, choose a command from the Insert or 
Delete icon’s drop-down menu. 

Figure 11.18 You can 
append rows or columns 
to a table by dragging the 
lower-right corner.

Figure 11.19 You can delete table rows 
or columns by choosing a command 
from the Delete icon’s menu.
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✔ Tips

■ You can also use the Delete Sheet Rows 

and Delete Sheet Columns commands in 

the Delete icon’s drop-down menu to 

modify a table. However, unlike the 

equivalent Delete Table commands, the 

Delete Sheet commands also affect data 

outside of the table.

■ You can also resize a table by entering a 

new range. Select a cell in the table, switch 

to the Design tab, and click the Resize 

Table icon in the Properties group. Type 

a new range in the Resize Table dialog 

box (Figure 11.20) or manually select the 

range on the worksheet, and then click OK. 

Unlike resizing by dragging (see Figure 

11.18), you can use the Resize Table dialog 

box to add new rows and columns at the 

same time.

■ You can move a table to a new location 

using cut-and-paste or drag-and-drop. 

Select the table, and then do one of the 

following:

▲ Cut-and-paste. Press cX or 

click the Cut icon in the Home tab’s 

Clipboard group. In the destination 

location, click the cell that will serve 

as the table’s new upper-left corner, 

and press e to perform the paste.

▲ Drag-and-drop. Move the cursor over 

any corner or edge of the table. When 

the cursor changes to a plus symbol 

with four arrowheads, click and drag 

the table to the new location.

Selecting Table Rows or Columns

To select a table column rather than an 

entire worksheet column, move the cursor 

over the top edge of the column header. 

When the cursor changes to a black down-

pointing arrow, click to select the table 

column. 

Similarly, to select a table row, move the 

cursor over the left edge of the row. When 

the cursor changes to a black right-pointing 

arrow, click to select the table row. 

Figure 11.20 Rather than dragging to append new 
rows or columns to a table, you can type a new range.
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Printing Tables
You can print a table as part of the current 

worksheet. On the other hand, there may be 

instances when you prefer to print only the 

table—without printing any of the surround-

ing worksheet cells.

To print a table:

1. Select the table or a cell within the table 

that you want to print.

2. Click the File tab to display the Backstage.

3. Click Print.

The Print settings screen appears.

4. In the Settings area, choose Print Selected 

Table from the top drop-down menu 

(Figure 11.21).

5. Change other print settings as desired, 

such as the orientation and printer.

As you select and change settings, the print 

preview (Figure 11.22) changes to reflect 

the new settings.

6. Click the Print button.

The table is sent to the designated printer, 

the Backstage closes, and the worksheet 

reappears.

✔ Tip

■ You can also print a table by preselecting 

the entire table on the worksheet and 

then choosing Print Selection from the 

same drop-down menu.

Figure 11.21 To print only a selected table, choose 
Print Selected Table from the drop-down menu.

Print preview

Figure 11.22 A print preview reflects the current print 
settings (in this case, printing only a selected table).

Print button
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In Excel, you can create charts and graphs 

to display your data visually. Although many 

kinds of charts can be made from tiny data 

sets, charts are especially useful for present-

ing and summarizing large quantities of data. 

A normal Excel chart is a floating object. As 

such, you can move a chart to any convenient 

location on the worksheet or change its size 

by dragging a corner. You can customize 

almost any part of a chart, such as its title, 

axis labels, legend, chart wall, or chart floor. 

You can also choose which optional elements 

to display and which ones to hide, such as data 

labels, gridlines, or the data itself. Finally, if 

you aren’t satisfied with the current chart 

style, you can replace it with a variation or a 

completely different kind of chart.

Office 2010 introduces a new chart type called 

sparklines. Rather than float as normal charts 

do, the tiny sparklines charts are displayed in 

cells just as data normally is.

Excel’s charting tools are also used to create 

charts in PowerPoint, Word, and Outlook. 

Charts in these non-Excel documents can be 

embedded (static objects that are unlinked 

from the worksheet data) or linked (objects 

that are linked with the data and automati-

cally reflect changes to it).

Creating Charts
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Objects and Charts

You can embellish your worksheets and 

charts by inserting objects, such as shapes, 

pictures, SmartArt, clip art, and screen shots. 

For instructions on inserting, resizing, 

moving, and rotating objects, see Chapter 3.

  



ptg

224

CCChhhaaapppttteeerrr   1113
C

h
a

r
t

 E
l
e

m
e

n
t

s

2

Chart Elements
Designing a chart is similar to creating art. 

You can freely add or remove elements, move 

them to new positions, and change their 

size, shape, and formatting. (Of course, you 

are free to accept the default elements and 

formatting used in a newly created chart, but 

you’re unlikely to do so very often.)

Because you’ll spend so much time working 

with chart elements, it’s important that you 

be able to identify each element. Note that 

many of the ones shown below (Figure 12.1) 

are optional.

Chart TitleData Label Legend

Data Table

GridlineAxis Labels

Axis Title Floor

WallData PointAxis Title

Figure 12.1 A chart and its elements.

Axis Labels
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Creating a Chart
In many instances, creating a chart is as 

simple as selecting the labels and data on 

the worksheet and then picking a chart type. 

Your chart data can be arranged in columns 

or rows. However, the columns or rows must 

be in a specific order for some types of charts.

To create a chart:

1. If necessary, rearrange the data so it con-

forms to the chart’s requirements.

For example, to create one type of stock 

chart, the data must be in High, Low, 

Close order. For other chart requirements, 

see “Create a chart from start to finish” in 

Excel Help.

2. Optional: Sort the data to ensure that it 

will be in the desired order when charted.

3. On the worksheet, select the labels and 

data from which the chart will be created.

Labels and data don’t need to be contigu-

ous. For example, in Figure 12.2, column B 

contains the labels and columns I, J, and K 

contain the data.

4. On the Insert tab, choose a chart type 

from a Charts group icon’s drop-down 

menu (Figure 12.3).

The new chart appears (Figure 12.4).

✔ Tips

■ If you select a chart’s plot area, the labels 

and data used to create the chart are 

highlighted in the worksheet. You can also 

select the data by switching to the Design 

tab and clicking the Select Data icon in 

the Data group.

■ To change the chart type or style, select 

the chart, click the Design tab, and click 

Change Chart Type in the Type group 

(Figure 12.5).

■ To delete a chart, select it and press d.

Figure 12.3 Specify the chart type by clicking an icon 
in the Charts group and choosing a chart style from 
the drop-down menu that appears.

Figure 12.2 In this example, column B (labels) and 
columns I, J, and K (data) have been selected.

Figure 12.4 Excel adds the chart as a floating object 
on the worksheet.

Figure 12.5 You can change an existing chart’s type 
and/or style by clicking an icon in the Change Chart 
Type dialog box.
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Changing the Background
If you aren’t satisfied with the background 

formatting on a generated chart, you can 

change it. You can apply formatting to the 

entire chart, the plot area, or the legend, as 

well as to objects you’ve placed on the chart, 

such as a title.

To change the background for the 
chart or a component:

1. Select the chart or component you want 

to format, such as the plot area, wall, floor, 

or legend.

2. Do one of the following:

▲ On the Format tab, choose formatting 

options from the Shape Styles group 

(Figure 12.6).

▲ On the Format or Layout tab, click the 

Format Selection icon in the Current 

Selection group.

▲ Right-click the selected area and 

choose Format item from the context 

menu. In the Format item dialog box 

(Figure 12.7), set formatting options 

and click Close.

✔ Tips

■ To easily select a particular chart element, 

switch to the Format or Layout tab and 

choose the element from the drop-down 

menu at the top of the Current Selection 

group. Then click the Format Selection 

icon in the same group.

■ You can also modify chart formatting by 

choosing options from the Background 

group (Figure 12.8) on the Layout tab.

Figure 12.6 You can add an outline, fill, and effects to 
a selected chart component by selecting options from 
the Shape Styles group.

Figure 12.7 To simultaneously modify several format-
ting options, select settings in a Format dialog box.

Figure 12.8 To change the wall, floor, or 
rotation of the plot area, choose options 
from the Background group.
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Adding and Formatting Text
Although primarily visual, charts can also 

include a prodigious amount of text. You can 

add a title, legend, grid division labels, axis 

labels, data labels, and text boxes.

To add a text item to a chart:

1. Select the chart.

2. On the Chart Tools contextual tab, select 

the Layout tab.

3. Do any of the following:

▲ Add a chart title. Click Chart Title in 

the Labels group and choose an 

option from the drop-down menu 

(Figure 12.9).

▲ Add an axis title. Click Axis Titles 

in the Labels group and choose an 

option from a Horizontal Axis Title or 

Vertical Axis Title submenu.

▲ Label the data. Click Data Labels 

in the Labels group and choose an 

option from the drop-down menu. 

Labeling options vary by chart type 

(Figure 12.10).

▲ Show chart data. Click Data Table in 

the Labels group and choose a Show 

option from the drop-down menu. 

Doing so displays the chart data in a 

grid beneath the plot area.

▲ Add other text. Click Text Box in the 

Insert group. Click and drag to create a 

text box on the chart, and then type or 

paste the text into the box.

Figure 12.9 Add a title and set its initial position 
by choosing an option from the Chart Title drop-
down menu.

Data label

Figure 12.10 Depending on the chart type, it can be 
useful to display the data on chart elements.
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To format chart text:

1. Do either of the following:

▲ Select the text object. (Select an object 

when you want to apply the same 

formatting to all text within the object.) 

▲ Within a text object, select the specific 

text to be formatted. (Only certain chart 

objects allow this, such as a title, axis 

label, or text box.)

2. Do any of the following:

▲ On the Home tab, choose formatting 

options from the Alignment group or 

the Font group (Figure 12.11).

▲ Right-click the selected object or text 

string, choose Font from the context 

menu (Figure 12.12), select format-

ting options from the Font dialog box 

(Figure 12.13), and click OK.

▲ With text selected, move the cursor up 

and choose formatting options from 

the Mini toolbar (Figure 12.12). 

▲ On the Format tab, choose options 

from the WordArt Styles group.

✔ Tips

■ Another way to format a text object is to 

choose More text object Options from the 

element’s drop-down menu in the Labels 

group (see Figure 12.9). A Format dialog 

box appears in which you can apply a 

background fill, specify a border style and 

color, add a shadow, and so on.

■ To remove most text objects, select the 

object and press d. You can also remove 

a specific label type by switching to the 

Layout tab, clicking the proper icon in the 

Labels group, and choosing None. For 

example, you can remove a chart title by 

choosing None from the Chart Title icon 

(see Figure 12.9).

Figure 12.11 You can apply text formatting by 
choosing commands from the Font group.

Mini toolbarSelected object

Figure 12.12 You can right-click objects that contain 
text and choose Font from the context menu.

Figure 12.13 For complex text-formatting needs, you 
may prefer to use the Font dialog box.
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Rows or Columns
Regardless of how your data is organized on 

the worksheet, you can plot it by rows or by 

columns. With many types of charts, plotting 

it both ways can give you a new perspective 

on the data.

To switch rows and columns:

1. Select the chart.

2. In the Data group within the Design tab, 

click the Switch Row/Column icon.

The chart updates to reflect the change 

(Figure 12.14).

Figure 12.14 By switching rows and columns, you can 
view the wins, places, and shows for each horse (top) 
or see how the seven horses compare on number of 
wins, places, and shows (bottom).
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Changing Layout and Style
One of the simplest ways to modify a chart is 

to specify a new layout or style. Layout refers 

to the elements appearing on the chart and 

their positions. Style refers to the coloring of 

chart elements, including the data objects, 

plot walls, and surrounding background.

 To specify a new layout:

1. Select the chart.

2. On the Design tab, click an icon in the 

Chart Layouts group (Figure 12.15).

The chart is modified to match the selected 

layout (Figure 12.16).

3. If previously undefined text elements 

appear in the chart (such as a title or axis 

titles), you can delete them or change 

their text.

To change the chart style:

1. Select the chart.

2. On the Design tab, choose a different style 

from the Chart Styles group (Figure 12.17).

The chart is modified to match the chosen 

chart style.

✔ Tips

■ Choosing a new chart style is a destruc-

tive process. Elements you’ve manually 

formatted, such as gridlines or the back-

ground, are replaced with the features 

specified in the new style.

■ When choosing a new chart layout or 

style, you can scroll through one line of 

options at a time by clicking the up and 

down scroll arrows. To view all options 

simultaneously as a gallery, click the bot-

tom arrow (Figure 12.15).

Figure 12.16 The pie chart is automatically modified 
to match the chosen layout.

Figure 12.15 Choose a new chart layout from 
the Chart Layouts group.

Click to view as gallery

Figure 12.17 To change the style for a selected chart, 
choose a new style from the Chart Styles gallery. 
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Displaying the Data Set
If a chart is based on a small data set, it can be 

informative to show the data table on the chart.

To display the data on the chart:

1. Select the chart.

2. Do one of the following:

▲ On the Layout tab, choose a data 

display option from the Data Table 

drop-down menu in the Labels group.

▲ On the Design tab, choose a layout from 

the Chart Layouts group that includes 

the data table.

The data table is added to the chart 

(Figure 12.18).

3. If necessary, resize the chart.

✔ Tips

■ To remove the data table, choose None 

from the Data Table drop-down menu or 

choose a layout from the Chart Layouts 

group that doesn’t includes the data table.

■ Another way to show data is to place it 

directly on chart items, such as bars and 

pie slices. On the Layout tab, choose an 

option from the Data Labels drop-down 

menu in the Labels group.

Figure 12.18 The data and legend can be combined 
(shown here) or  displayed as separate chart items. 

Legend Data table
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Working with Gridlines
To make it easier to estimate the size of data 

points, you can display horizontal and/or 

vertical lines called gridlines (Figure 12.19)

on many kinds of charts. You can modify 

gridlines by removing them; displaying major, 

minor, or both types of gridlines for an axis; 

and setting a new line color or style.

To add, remove, or modify gridlines:

1. Select the chart.

2. On the Layout tab, click the Gridlines 

icon in the Axes group and choose one of 

the following options from the Primary 

Horizontal Gridlines, Primary Vertical 

Gridlines, or Depth Gridlines submenu 

(Figure 12.20):

▲ None. Remove all gridlines of the 

chosen type.

▲ Major Gridlines. Display major data 

divisions on the chosen axis, such as 

1–5 or integers divisible by 5, 10, or 25 

(depending on the size and spread of 

the data).

▲ Minor Gridlines. Display subdivisions 

between major gridlines (whether or 

not major gridlines are visible).

▲ Major & Minor Gridlines. Display 

both major and minor gridlines for the 

chosen axis.

▲ More Primary Gridlines Options. 

Open a Format dialog box to set color, 

style, shadow, glow, or soft edges for 

horizontal or vertical primary gridlines. 

Select new settings and click Close.

The chosen option is applied to the chart.

✔ Tips

■ The Depth Gridlines submenu appears 

only when a true 3-D chart is selected 

(Figure 12.21).

■ You can also remove gridlines by right-

clicking them on the chart and choosing 

Delete from the context menu.

Figure 12.19 Gridlines behind the data can make it 
easier to see or estimate the size of data points.

Figure 12.20 A Gridlines submenu.

Figure 12.21 A true 3-D chart has depth.
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Working with the Legend
If you select row or column labels when cre-

ating a chart, a legend (key to the data series) 

is generally added to the chart (Figure 12.22). 

You can add or remove the legend, specify its 

placement in relation to the chart, change its 

properties (such as fill color and border style), 

and edit its labels.

To add, remove, or modify the legend:

1. Select the chart.

2. Do any of the following:

▲ To add, remove, or change the position 

of the legend, click the Layout tab and 

choose an option from Legend menu 

in the Labels group (Figure 12.23).

▲ To manually change the size or posi-

tion of the legend, drag an edge or the 

center, respectively.

▲ To format the legend, right-click it, 

choose Format Legend from the context 

menu, and make the desired changes 

in the Format Legend Entry dialog box 

(Figure 12.24).

▲ To change the properties of a single 

data series, select that element in the 

legend, right-click it, choose Format 

Data Series or Format Legend Entry, 

and make any desired changes in the 

Format Data Series or Format Legend 

Entry dialog box.

▲ To modify the text used for legend 

entries, make the edits in the worksheet 

cells you used as labels.

✔ Tips

■ You don’t have to close a Format dialog 

box immediately. To format a different

chart element, select that element on the 

chart. The Format dialog box changes to 

one appropriate for the selected element.

Legend

Figure 12.22 The legend serves as a key to the chart. 
Each element in the legend represents a data series.

Figure 12.23 Add, remove, 
or change the placement 
of the legend by choosing 
an option from this menu.

Legend icon

Figure 12.24 You can specify a new location or custom 
formatting in the Format Legend dialog box.

■ You can also open the Format Legend 

dialog box by double-clicking the legend.
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Adding Trendlines
If data is gathered over time, you can add 

lines called trendlines to the chart that sum-

marize the data and predict future values. 

Depending on the data set, different trendline 

types may provide a better fit to the data.

To add a trendline:

1. Select the chart.

2. On the Layout tab, click the Trendline 

icon in the Analysis group and choose an 

option from the drop-down menu.

If the chart includes multiple data series, 

an Add Trendline dialog box appears. 

Select the data series to which the trend-

line will be applied and click OK.

The trendline appears on the chart.

3. Optional: To modify a trendline’s proper-

ties or type, select the trendline. Open the 

Format Trendline dialog box (Figure 12.25) 

by doing one of the following:

▲ Right-click the trendline and choose 

Format Trendline.

▲ Choose More Trendline Options from 

the Trendline drop-down menu.

4. Make the desired changes and click Close. 

The new settings are reflected on the chart 

(Figure 12.26).

✔ Tips

■ Adding trendlines is cumulative. That is, 

you can plot multiple types of trendlines 

on the same chart.

■ To remove all trendlines from a chart, 

choose None from the Trendline drop-

down menu. To remove one trendline 

(when multiple trendlines are displayed), 

select the trendline on the chart and  

press d.

■ You may also want to explore these other 

options in the Analysis group:

▲ Lines. Show high-low marks (especially 

useful for stock charts) and/or drop 

lines that extend up from the X axis to 

each data point. 

▲ Error Bars. Surround each data point 

with bars showing a confidence inter-

val based on a percentage, standard 

deviation, or standard error.

Figure 12.26 A trendline on a stock chart.

Trendline R2 value

Figure 12.25 The Format Trendline dialog 
box offers additional options, such as other 
trendline types and displaying predicted 
values, based on the trendline.
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Modifying the Axes
Most charts have a horizontal (X) and a verti-

cal (Y) axis. You can modify either axis by 

changing its labels or formatting.

To modify an axis:

1. Select the chart.

2. Do any of the following:

▲ To remove an axis, set the position of 

the Y axis, or specify numeric units to 

use for the X axis, click the Layout tab 

and choose an option from the Axes 

drop-down menu in the Axes group 

(Figure 12.27).

▲ To change the formatting for an axis, 

right-click the axis labels on the chart 

and choose Format Axis, or choose 

More axis name Axis Options from 

the Axes menu (Figure 12.27). Make 

changes in the Format Axis dialog box 

and click Close.

▲ To change an individual axis label, edit 

the label’s text in its worksheet cell. 

You can also modify axis labels in the 

Select Data Source dialog box. Click 

the Design tab, and click the Select 

Data icon in the Data group.

▲ To add a title to the horizontal or ver-

tical axis, choose a display option from 

the appropriate Axis Titles submenu 

on the Layout tab. A title containing 

placeholder text appears on the chart 

(Figure 12.28). Edit the placeholder 

text and then change the formatting, if 

you wish.

Figure 12.28 You can add a title 
to either or both axes.

Vertical axis  
title placeholder

Vertical

Figure 12.27 Because the horizontal and vertical axes 
serve different purposes, each has different options. 

Horizontal
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Creating Sparklines
New in Office 2010, sparklines (Figure 12.29) 

are tiny charts that display and summarize 

data. Unlike normal charts that are floating, 

resizable objects, sparklines are presented 

in individual cells, visually linking them with 

their data.

To add sparklines:

1. Select the data range or the range into 

which you want to insert the sparklines.

2. Click the Insert tab. In the Sparklines 

group (Figure 12.30), click a sparkline 

format icon. 

The Create Sparklines dialog box appears 

(Figure 12.31).

3. Fill in the two range text boxes by typing 

or drag-selecting on the worksheet. 

If you preselected a range in Step 1, it will 

already be specified in the dialog box. Edit 

it, if necessary.

4. Click OK.

The sparklines appear in the designated 

Location Range.

✔ Tips

■ As with other Excel charts, if you edit the 

data on which sparklines are based, the 

sparklines automatically update.

■ To change their style or formatting, select 

the sparklines and set new options on the 

Design tab (within the Sparkline Tools 

contextual tab). 

■ You can change the formatting of an 

individual sparkline by selecting only its 

cell, rather than all sparkline cells. 

■ Sparkline cells can also contain data.

■ To remove all or selected sparklines, 

choose a Clear command from the Group 

group on the Design tab.

Sparklines

Figure 12.29 In this example, column sparklines show 
each student’s three test scores.

Figure 12.30 Select a sparkline 
format by clicking an icon.

Figure 12.31 Specify the data range and location 
range for the sparklines.
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Changing the Chart Data
Even if you’ve created a chart and carefully 

formatted it exactly the way you wanted, 

a problem sometimes occurs. The data on 

which the chart is based changes! A column 

or row in the data source may need to be 

deleted, data in one or more cells may need 

to be edited, or you may want to include 

additional rows or columns.

To modify chart data: 

1. Select the chart.

2. Do any of the following:

▲ Edit existing data. If you edit data in 

the cells on which the chart is based, 

the chart automatically updates to 

reflect the edited data.

▲ Delete rows or columns. If you delete 

rows or columns within the range(s) 

used to create the chart, the data is 

automatically removed from the chart.

▲ Add new rows or columns. Adding 

new rows or columns within the range 

of the original chart data triggers an 

update of the chart.

To add new rows that are immediately 

adjacent to the existing rows, select 

the chart. This causes the original chart 

data to be selected on the worksheet. 

Drag a corner of the data selection 

rectangle to encompass the new rows 

or columns (Figure 12.32).

✔ Tip

■ You can also add new data to a chart by 

switching to the Design tab and clicking 

the Select Data icon in the Data group. 

The Select Data Source dialog box appears 

(Figure 12.33). Edit the ranges in the 

dialog box or select new ranges on the 

worksheet. Click OK.

Specify a new range

Figure 12.33 To change the data on which a chart 
is based, edit the ranges in the Select Data Source 
dialog box or select new ranges on the worksheet.

Figure 12.32 With the chart selected, drag a corner 
handle of the data selection rectangle to select the 
original and new data.

Original chart data
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